[torqueusers] Compiling Torque in Cygwin

Garrick Staples garrick at usc.edu
Thu Sep 11 10:15:09 MDT 2008


On Wed, Sep 10, 2008 at 12:24:52PM -0400, Darcy Quick alleged:
> Has anyone had luck getting Torque working in Cygwin?  I need to run a 
> pbs_mom on a Windows node.  There's no mention of it in the OS notes in 
> INSTALL.

There is README.cygwin in the source tarball.

As already noted, clients will build.  The server builds, but is untested.  mom
does not build.

 
> Configure options used:
> ./configure --disable-gcc-warnings
> 
> I got the following errors running make with torque 2.3.3:
> gcc -DHAVE_CONFIG_H -I. -I. -I../../../src/include 
> -I../../../src/include -I../Libdis 
> -DIFF_PATH=\"/usr/local/sbin/pbs_iff\" 
> -DPBS_DEFAULT_FILE=\"/var/spool/torque/server_name\" -g -MT 
> pbsD_connect.lo -MD -MP -MF .deps/pbsD_connect.Tpo -c 
> ../Libifl/pbsD_connect.c  -DPIC -o .libs/pbsD_connect.o
> ../Libifl/pbsD_connect.c: In function `send_unix_creds':
> ../Libifl/pbsD_connect.c:550: error: `SCM_CREDENTIALS' undeclared (first 
> use in this function)

configure should have detected this properly, but cygwin is weird.

Try --disable-unixsockets.

-- 
Garrick Staples, GNU/Linux HPCC SysAdmin
University of Southern California

Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20080911/08352572/attachment-0001.bin


More information about the torqueusers mailing list