[torqueusers] pbs_mom unable to chdir to automounted dirs

Mary Ellen Fitzpatrick mfitzpat at bu.edu
Wed Oct 22 07:21:03 MDT 2008


Thanks Steve.  Yes I already have my config file listed as such
$usecp *:/fs/userB1 /fs/userB1

Once the /fs/userB1 is automounted, I get all of my output files 
delivered properly.  Just seems like pbs_mom needs to tell the compute 
node to mount /fs/userB1 before running the job.


Steve Young wrote:
> Hi,
> 	I'm not for certain but I wonder if you put this in your mom_priv/ 
> config on your nodes?
>
> $usecp *:/home /home
>
> (of course change the /home to your directory names). Hope this helps,
>
> -Steve
>
>
>
> On Oct 21, 2008, at 4:20 PM, Mary Ellen Fitzpatrick wrote:
>
>   
>> I have my home dirs nfs exported to all of my compute nodes.  I can  
>> log into the nodes and cd the nfs mounted dirs, no problem. When I  
>> submit a job to a node and the automounted nfs dirs are not mount  
>> (timed out), I get the following error:
>>
>> Oct 21 16:08:14 node1047 pbs_mom: No such file or directory (2) in  
>> TMomFinalizeChild, PBS: chdir to '/fs/userB1/mfitzpat' failed: No  
>> such file or directory
>>
>> If I immediately resubmit the job to the same node, it will run.  It  
>> appears that pbs wants the automounted nfs dirs to be already  
>> mounted, then the job will run.  If I hard mount the nfs home dirs,  
>> I have no problem running the jobs, but I do not want to do that.
>>
>> Any one run into this?  Trying to figure out if it is a torque issue  
>> or automount issue.
>>
>> -- 
>> Thanks
>> Mary Ellen
>>
>> _______________________________________________
>> torqueusers mailing list
>> torqueusers at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>     
>
>
>   

-- 
Thanks
Mary Ellen



More information about the torqueusers mailing list