[torqueusers] assigning specific nodes to queues

Greenseid, Joseph M. Joseph.Greenseid at ngc.com
Fri Oct 3 09:16:20 MDT 2008


Worked like a charm.  Thanks, Steve!
 
--Joe

________________________________

From: Steve Young [mailto:chemadm at hamilton.edu]
Sent: Fri 10/3/2008 10:58 AM
To: Greenseid, Joseph M.
Cc: torqueusers at supercluster.org
Subject: Re: [torqueusers] assigning specific nodes to queues


Hi, 
I constrain nodes to queue's without using acl_hosts. All I do is put a feature in the server's node file like this:

node01 altix
node02 altix
node03 mac
node04 mac

then I have this in the configuration for each queue in torque:

set queue altix resources_default.neednodes = altix

set queue mac resources_default.neednodes = mac

That seems to do it for me. Hope this helps. 

-Steve



On Oct 3, 2008, at 8:48 AM, Greenseid, Joseph M. wrote:


	
	
	hi,
	 
	i saw in the archives that this has been asked before, but i didn't see that there was ever resolution, so i apologize in advance for asking again if there was an i missed it.
	 
	i am trying to define a queue named "test," and have two nodes specifically assigned to it.  
	 
	the test queue is defined as such:
	 
	create queue test
	set queue test queue_type = Execution
	set queue test acl_host_enable = False
	set queue test acl_hosts = compute-12-13.hpcc.local
	set queue test acl_hosts += compute-12-12.hpcc.local
	set queue test resources_max.cput = 01:00:00
	set queue test resources_max.ncpus = 16
	set queue test resources_max.nodect = 2
	set queue test resources_max.walltime = 01:00:00
	set queue test resources_min.cput = 00:00:01
	set queue test resources_min.ncpus = 1
	set queue test resources_min.nodect = 1
	set queue test resources_min.walltime = 00:00:01
	set queue test resources_default.cput = 00:30:00
	set queue test resources_default.ncpus = 1
	set queue test resources_default.nodect = 1
	set queue test resources_default.walltime = 00:30:00
	set queue test resources_available.nodect = 2
	set queue test enabled = True
	set queue test started = True

	 

	however, when i try to run a job in this queue (in my job script, i specify "#PBS -q test"), it not running on either of these two nodes.  i have tried changing the attributes of these two nodes in the nodes file to be of the form "compute-12-12.hpcc.local np=8 test" but that didn't help, either.  

	 

	i am running a slightly older version, 2.1.8, but that cannot be helped for the time being, and there was nothing in the documentation i saw that said this was specific to certain versions.  

	 

	did i miss something?

	 

	thanks,
	--Joe
	_______________________________________________
	torqueusers mailing list
	torqueusers at supercluster.org
	http://www.supercluster.org/mailman/listinfo/torqueusers
	


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20081003/bbfa0f4f/attachment-0001.html


More information about the torqueusers mailing list