[torqueusers] configure warning when install torque-2.3.4

Weiguang Chen chenweiguang82 at gmail.com
Thu Nov 13 02:11:28 MST 2008


Hi,
I am going to upgrade our torque to version 2.3.4, first i executed
./configure, and a warning show in the last:

Building components: server=yes mom=yes clients=yes
                     gui=yes drmaa=no pam=no
PBS Machine type: linux
Remote copy: /usr/bin/scp -rpB
PBS home: /var/spool/torque
Default server: node1
Unix Domain sockets: yes
Tcl: -L/usr/lib64 -ltclx8.3 -L/usr/lib64 -ltcl8.4 -ldl -lieee -lm
Tk: -I/usr/X11R6/include -L/usr/lib64 -ltkx8.3 -L/usr/lib64 -ltk8.4
-L/usr/X11R6/lib64 -lX11 -L/usr/lib64 -ltclx8.3 -L/usr/lib64 -ltcl8.4 -ldl
-lieee -lm


configure: WARNING: This compilation has strict compiler options enabled
that cause
the build to fail if any compiler warnings are emitted.  If this build fails
because of a harmless warning, please report the problem to
torqueusers at supercluster.org
and run configure again with --disable-gcc-warnings.

Ready for 'make'.

our gcc version:
[root at node1 torque-2.3.4]# gcc -v
Reading specs from /usr/lib/gcc/x86_64-redhat-linux/3.4.6/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk
--host=x86_64-redhat-linux
Thread model: posix
gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)

Is this WARNING fatal?
How to solve it?

Thanks
-- 
Best Wishes
ChenWeiguang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20081113/83c2eca2/attachment.html


More information about the torqueusers mailing list