[torqueusers] Problem making Torque RPMs on RHEL/CentOS 4.7 on ia64/Itanium via rpmbuild

Jack Challen jack_challen at ocsl.co.uk
Mon Nov 10 03:56:17 MST 2008


[Replied from the wrong address; this one should actually hit the list]


Josh Butikofer wrote:
> If you want to try out my changes using the tarball you already 
> downloaded, please try applying the attached patch and recompiling. It 
> should hopefully allow you to use -O2 again without 
> --disable-gcc-warnings (unless there are other issues in the code that 
> your compiler won't like).

That patch worked perfectly, thanks. I'm now using 2.3.3.


> This has also been fixed in the 2.3.4 snapshots and the fix will be 
> permanent when TORQUE 2.3.4 is released (which should be soon).

I must admit, I didn't try the snapshots at first. I've tried them over the weekend, and I encountered problems with
TORQUE_REVISION being undefined. If I added a -DTORQUE_REVISION=blah then compilation got further, but then stopped on
another error. I can't remember precisely what that error was (sorry), but I'll try to get some time to have another
crack at it on ia64, unless that would serve no purpose.

cheers
jack

-- 
Jack Challen
Technical Consultant, OCSL.
http://www.ocsl.co.uk/

This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail.


More information about the torqueusers mailing list