[torqueusers] Problem making Torque RPMs on RHEL/CentOS 4.7 on ia64/Itanium via rpmbuild

Garrick Staples garrick at usc.edu
Fri Nov 7 11:50:58 MST 2008


On Fri, Nov 07, 2008 at 10:47:28AM +0000, Jack Challen alleged:
> Hello,
> 
> I'm attempting to build Torque v2.3.3 using rpmbuild or "make rpm", as I'd 
> like the final files to belong to an RPM package (for ease of upgrading, 
> package distribution, etc). Both methods fail due to the strict compiler 
> warnings (I have a work-around), but the plain "make" works as expected.
> This is on an Itanium (ia64) machine running either RHEL 4.7 or CentOS 4.7 
> (I've tried both with the same result). x86_64 machines don't exhibit this 
> problem.
> 
> 
> There's also a small problem with the torque.spec file: it doesn't include 
> pbs_track in the client "files" definition, which applies to other 
> architectures too -- see Attempt 4.
> 
> 
> 
> Attempt 1:
> rpmbuild -tb torque-2.3.3.tar.gz
> ===
[..snip..]

Use 'make rpm' to create rpms exactly as you've configured them.

Add pbs_track to torque.spec.in (this is fixed in svn).
./configure --disable-gcc-warnings
make rpm


-- 
Garrick Staples, GNU/Linux HPCC SysAdmin
University of Southern California

Revoke LDS Church 501(c)(3) Status - http://lds501c3.wordpress.com/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20081107/4ff4d42a/attachment.bin


More information about the torqueusers mailing list