[torqueusers] Problem making Torque RPMs on RHEL/CentOS 4.7 on ia64/Itanium via rpmbuild

Josh Butikofer josh at clusterresources.com
Fri Nov 7 11:32:25 MST 2008


Jack,

See my comments below:

Jack Challen wrote:
> Hello,
> 
> I'm attempting to build Torque v2.3.3 using rpmbuild or "make rpm", as 
> I'd like the final files to belong to an RPM package (for ease of 
> upgrading, package distribution, etc). Both methods fail due to the 
> strict compiler warnings (I have a work-around), but the plain "make" 
> works as expected.
> This is on an Itanium (ia64) machine running either RHEL 4.7 or CentOS 
> 4.7 (I've tried both with the same result). x86_64 machines don't 
> exhibit this problem.

I only have a ia64 machine running CentOS 3.8, so I'm not able to 
reproduce your problem exactly, but based on the compiler warnings you 
posted here I believe this has been fixed in the latest 2.3.4 snapshot 
of TORQUE 
(http://www.clusterresources.com/downloads/torque/snapshots/torque-2.3.4-snap.200811071123.tar.gz 
  ).

If you want to try out my changes using the tarball you already 
downloaded, please try applying the attached patch and recompiling. It 
should hopefully allow you to use -O2 again without 
--disable-gcc-warnings (unless there are other issues in the code that 
your compiler won't like).

> There's also a small problem with the torque.spec file: it doesn't 
> include pbs_track in the client "files" definition, which applies to 
> other architectures too -- see Attempt 4.

This has also been fixed in the 2.3.4 snapshots and the fix will be 
permanent when TORQUE 2.3.4 is released (which should be soon).

Regards,

Josh Butikofer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ia64.patch
Type: text/x-diff
Size: 852 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20081107/537626d2/ia64.bin


More information about the torqueusers mailing list