[torqueusers] X forwarding in interactive session

Garrick Staples garrick at usc.edu
Wed May 28 12:41:58 MDT 2008


On Wed, May 28, 2008 at 09:58:06AM -0400, Martins, Flavio alleged:
> Thanks to all who responded. I think I have made some progress with this
> issue, although I still have not gotten it to work. I will try to
> address most of the comments made all at once here:
> 
>  
> 
> 1) I can run any X application on my master (login) node without any
> problems. If I ssh -X into the cluster the $DISPLAY variable is set to
> something like localhost:12. If I rlogin I have to manually set $DISPLAY
> to workstation:0.0.

Use ssh.  rlogin doesn't tunnel X.  When you use rlogin, you are forced to run
X in the clear over the network.  ssh creates a secure tunnel.

This only works when you *don't* mess with $DISPLAY.  Let ssh set it
appropriately.
 

> 2) I think the -X from qsub does not work for me because I don't have
> ssh running on the nodes. Our cluster has a very bare-bones setup for
> the nodes and ssh is not part of the node configuration. I also don't
> have X running on the nodes - although I don't think that's necessary if
> I am forwarding the display elsewhere.

As others have said, qsub doesn't use ssh.  It's X forwarding is basicly the
same thing as ssh's X forwarding, but without the encrypted tunnel.

 
 
> 3) I tried to rlogin to the master node, set the DISPLAY variable to
> workstation:0.0 and issue a qsub -I -V. Once on the node, I checked the
> value of the DISPLAY variable and it was set to "workstation". It had
> lost the :0.0 part. I tried to set again manually but it did not work.
> Launching an X application just hangs. I can ping my workstation from
> the node, and I had access control disabled (vial xhost + command).

Never disable access control.  Anyone can easily take control of your machine,
steal your passwords, piss off your dog, and you'd never know.

If DISPLAY is set to workstation:0.0, access control is disabled, can ping the
workstation, and X clients hang, then you are dealing with a firewall problem.


> 4) if I rlogin, set the DISPLAY manually to workstation:0.0 and then
> issue a qsub -I -X, the DISPLAY variable gets set to localhost:50 once
> on the node, and X applications just hang.

Sounds like a firewall problem.
 

> I think the best course of action at this point is to configure the
> nodes to run ssh. I have discussed this issue with the developer of our
> cluster software and he said that although this is possible he would not
> recommend it as the applications would run very slow. Is that consistent
> with the experience of others?

As others have said, adding ssh won't fix this.

-- 
Garrick Staples, GNU/Linux HPCC SysAdmin
University of Southern California

Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20080528/386e23c8/attachment.bin


More information about the torqueusers mailing list