[torqueusers] problem with route queue

Fernando Malick fmalick at yahoo.com.ar
Mon Jun 16 12:59:31 MDT 2008


I have defines a route queue:

# qstat -Qf route
Queue: route
    queue_type = Route
    total_jobs = 0
    state_count = Transit:0 Queued:0 Held:0 Waiting:0 Running:0 Exiting:0
    mtime = 1213631082
    route_destinations = small,medium,large
    enabled = True
    started = True

And three execution queue:

# qstat -Qf small
Queue: small
    queue_type = Execution
    total_jobs = 11
    state_count = Transit:0 Queued:0 Held:0 Waiting:0 Running:1 Exiting:0
    resources_max.ncpus = 1
    resources_max.nodes = 1
    resources_max.vmem = 512mb
    resources_min.vmem = 1mb
    resources_default..nodes = 1
    resources_default.vmem = 128mb
    resources_default..walltime = 01:00:00
    mtime = 1213630118
    resources_assigned.mem = 419430400b
    resources_assigned.ncpus = 1
    resources_assigned.nodect = 1
    resources_assigned.vmem = 134217728b
    enabled = True
    started = True

# qstat -Qf medium
Queue: medium
    queue_type = Execution
    total_jobs = 0
    state_count = Transit:0 Queued:0 Held:0 Waiting:0 Running:0 Exiting:0
    resources_max.ncpus = 2
    resources_max.nodes = 1
    resources_max.vmem = 1024mb
    resources_min.ncpus = 1
    resources_min.vmem = 1mb
    resources_default.nodes = 1
    resources_default.vmem = 128mb
    resources_default.walltime = 01:00:00
    mtime = 1213630118
    enabled = True
    started = True

# qstat -Qf large
Queue: large
    queue_type = Execution
    total_jobs = 0
    state_count = Transit:0 Queued:0 Held:0 Waiting:0 Running:0 Exiting:0
    resources_max.ncpus = 8
    resources_max.nodes = 1
    resources_max..vmem = 3800mb
    resources_min.ncpus = 1
    resources_min.vmem = 1mb
    resources_default.nodes = 1
    resources_default.vmem = 128mb
    resources_default.walltime = 01:00:00
    mtime = 1213630118
    enabled = True
    started = True

If I send a job that requires 2 cpus nad 400 Mb memory, I expected the job to go to the medium queue. However, the job is executed under the small queue.

The PBS script includes :
#PBS -l nodes=1:ppn=2,mem=400mb,walltime=6:00:00

Every job I send seems to fall into the small queue. I thought the resources values would make the job go to the medium queue.

__________________________________________________
Correo Yahoo!
Espacio para todos tus mensajes, antivirus y antispam ¡gratis! 
¡Abrí tu cuenta ya! - http://correo.yahoo.com.ar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20080616/36ab3381/attachment.html


More information about the torqueusers mailing list