[torqueusers] Question about prologue scripts and sending jobs back to queue.

Garrick Staples garrick at usc.edu
Wed Jan 23 17:24:43 MST 2008


On Wed, Jan 23, 2008 at 04:02:51PM -0700, John Hanks alleged:
> On Jan 23, 2008 3:14 PM, Garrick Staples <garrick at usc.edu> wrote:
> > On Wed, Jan 23, 2008 at 02:30:59PM -0700, John Hanks alleged:
> > > Moab 5.1.0.
> > >
> > > I found DEFERTIME and I think that'll solve my deferred issue. I'll
> > > have to read more about resources, I just assumed adding
> > > 'fakeresource' to my test nodes in my nodes file would be sufficient
> > > but it makes sense that I'd have to tell moab about it. Just need to
> > > figure out how.
> >
> > You don't necessarily have to tell moab about it.  Moab can read this stuff
> > from pbs_server.
> >
> 
> I added a NODECFG line to specify my fakeresource on a single node.
> Then I submitted a job and had things configured so that the health
> check would fail and offline the node. It worked, the job requeued
> then a minute later started on another node that didn't have the fake
> resource feature. I qsub'd a second job and it started directly on a
> node without the feature. Some snippets are:

Sounds like a bug in Moab. Open a case with CRI for Moab.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20080123/7f596bfe/attachment-0001.bin


More information about the torqueusers mailing list