[torqueusers] qsub -X much slower than ssh -X

Garrick Staples garrick at usc.edu
Mon Feb 11 12:53:49 MST 2008


On Mon, Feb 11, 2008 at 12:41:55AM -0500, Prakash Velayutham alleged:
> 
> On Feb 11, 2008, at 12:24 AM, Garrick Staples wrote:
> 
> >On Sun, Feb 10, 2008 at 10:50:20PM -0500, Prakash Velayutham alleged:
> >>Hello All,
> >>
> >>I recently noticed that performance of GUI-based applications like
> >>Matlab are much slower during a qsub -X session than a ssh -X  
> >>session.
> >>Matlab takes about 6 seconds to start up using qsub -X, but only 2
> >>seconds using ssh -X.
> >>
> >>Any idea why? What should I check in my Torque server/MOM  
> >>configuration?
> >
> >There wouldn't be any configs for this.  I'll test tomorrow at work.
> 
> Hi Garrick,
> 
> Thanks. I just did a test again and here are the numbers.
> 
> qsub -I -X to a node asking for all procs (4 in this case). Starting  
> up Matlab (no options/arguments, nothing) takes about 25-28 seconds to  
> get me the GUI with prompt inside Matlab command window.
> 
> ssh -X to a node which has no job running (with 4 CPUs) and starting  
> up Matlab takes about 10 seconds to bring the GUI with prompt.
> 
> Sorry about my earlier figures of 6 seconds and 2 seconds. Those were  
> just proportions.

I'm not able to replicate this result.  I've tried a few different i686 and
x86_64 nodes and no matter what I do, I get the splash screen in ~2 seconds and
the main window fully drawn in another ~2-4 seconds.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20080211/4719d781/attachment.bin


More information about the torqueusers mailing list