[torqueusers] Re: Resources not used

Enrico Morelli enrico.morelli at gmail.com
Fri Dec 5 06:51:45 MST 2008


I had find the problem. Was a wrong mom configuration of one node.

Thanks

On Fri, Dec 5, 2008 at 1:08 PM, Enrico Morelli <enrico.morelli at gmail.com>wrote:

> Dear all,
>
> I'm using torque 2.1.9 and maui 3.2.6p19 on a cluster with 32 processors.
> The problem that I don't understand is that I've set the maximum number of
> jobs = 32 for members of the projects group (see maui.cfg after), but I can
> launch only 27 jobs, the other jobs are queued.
>
> This is the showq:
>
> ACTIVE JOBS--------------------
> JOBNAME            USERNAME      STATE  PROC   REMAINING
> STARTTIME
> .
> .
>
> 11998                hemeup    Running     1 99:22:00:43  Fri Dec  5
> 11:03:03
> 12001                hemeup    Running     1 99:22:19:17  Fri Dec  5
> 11:21:37
> 12002                hemeup    Running     1 99:22:23:49  Fri Dec  5
> 11:26:09
>
>     27 Active Jobs      27 of   32 Processors Active (84.38%)
>                          4 of    4 Nodes Active      (100.00%)
>
> IDLE JOBS----------------------
> JOBNAME            USERNAME      STATE  PROC     WCLIMIT
> QUEUETIME
> .
> .
> .
> 12036                prodoc       Idle     1  4:00:00:00  Fri Dec  5
> 12:56:57
> 12037                prodoc       Idle     1  4:00:00:00  Fri Dec  5
> 12:56:57
> 9 Idle Jobs
>
> BLOCKED JOBS----------------
> JOBNAME            USERNAME      STATE  PROC     WCLIMIT
> QUEUETIME
>
>
> Total Jobs: 36   Active Jobs: 27   Idle Jobs: 9   Blocked Jobs: 0
>
>
> This is the maui.cfg (the jobs are submitted using a projects group
> member):
>
> RMPOLLINTERVAL        00:00:10
>
> DEFERTIME       00:01:00
> #############
> CLASSWEIGHT 1
> CREDWEIGHT 1
> USERWEIGHT 1
> GROUPWEIGHT 1
>
> SERVWEIGHT       1
> QUEUETIMEWEIGHT  10
> XFACTORWEIGHT           3
> XFWEIGHT                7
> XFCAP                   1000000
>
> ENABLEMULTIREQJOBS TRUE
> JOBPRIOACCRUALPOLICY QUEUEPOLICY
>
> JOBMAXSTARTTIME   01:00:00
> #############
> MAXJOBPERGROUPPOLICY    ON
> SMAXJOBPERGROUPCOUNT    32
> MAXJOBPERGROUPCOUNT     32
>
> MAXJOBQUEUEDPERUSERPOLICY       ON
> MAXJOBQUEUEDPERUSERCOUNT        5
> MAXJOBQUEUEDPERGROUPPOLICY      ON
> MAXJOBQUEUEDPERGROUPCOUNT      10
>
> SHORTPOOLPOLICY         ON
> SHORTPOOLMAXTIME        3600
> SHORTPOOLMINSIZE        1
> SHORTPOOLMINPCT         5
>
> GROUPCFG[projects] PRIORITY=10000 MAXPROC=32 MAXJOB=32,32 MAXJOBQUEUED=32
> CLASSCFG[cert] PRIORITY=10000 MAXJOB=2,40
> GROUPCFG[enmr] PRIORITY=1000 MAXPROC=32 MAXJOB=28,28 MAXJOBQUEUED=16
> CLASSCFG[short] PRIORITY=600 MAXJOB=24,28
> CLASSCFG[medium] PRIORITY=400 MAXJOB=14,16
> CLASSCFG[long] PRIORITY=200 MAXJOB=6,8
> CLASSCFG[verylong] PRIORITY=50 MAXJOB=1,2
>
> ENABLEMULTIREQJOBS TRUE
>
> Where is the wrong parameter?
>
> Thanks
> Enrico Morelli
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20081205/0310b0cf/attachment.html


More information about the torqueusers mailing list