[torqueusers] rpmbuild problem with torque-2.3.3

Gabe Turner gabe at msi.umn.edu
Mon Aug 18 10:06:21 MDT 2008


On Mon, Aug 18, 2008 at 12:51:48PM -0300, Albino Aveleda wrote:
> Hi,
> 
> I created rpm files for torque-2.3.2 without problem. When I tried to 
> create rpm files for torque-2.3.3 I received this error:
> 
> ...
> Processing files: torque-localhost-2.3.3-1cri
> Processing files: torque-devel-2.3.3-1cri
> Finding  Provides: /usr/lib/rpm/find-provides torque
> Finding  Requires: /usr/lib/rpm/find-requires torque
> Finding  Supplements: /usr/lib/rpm/find-supplements torque
> Provides: libtorque-devel
> Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1 
> rpmlib(CompressedFileNames) <= 3.0.4-1
> Requires: torque = 2.3.3-1cri /bin/sh
> Checking for unpackaged file(s): /usr/lib/rpm/check-files 
> /var/tmp/torque-2.3.3-buildroot
> error: Installed (but unpackaged) file(s) found:
>   /usr/local/torque/bin/pbs_track
> 
> 
> RPM build errors:
>    Installed (but unpackaged) file(s) found:
>   /usr/local/torque/bin/pbs_track
> 
> ----

You can add 

    %{_bindir}/pbs_track

to one of the %files sections in the spec file.  I added it to 
'%files client', but I'm thinking of adding it to '%files mom', as, as far
as I can tell, pbs_track will only be executed on compute nodes.

HTH,

Gabe

-- 
Gabe Turner                                             gabe at msi.umn.edu
UNIX System Administrator,
University of Minnesota
Supercomputing Institute                          http://www.msi.umn.edu


More information about the torqueusers mailing list