[torqueusers] pbs_mom no password entry for user

Mary Ellen Fitzpatrick mfitzpat at bu.edu
Fri Aug 1 12:00:07 MDT 2008


I ran  getent passwd mef   and it found the account.
I can ssh to the node as mef and log in with passwd as well.

Garrick Staples wrote:
> On Thu, Jul 31, 2008 at 04:15:39PM -0400, Mary Ellen Fitzpatrick alleged:
>   
>> Hi,
>> I have installed/configured torque-2.3.1 and maui-3.2.6p18 on my head 
>> node, nona-man.   I thought I had everything configured correctly, but 
>> apparantly not.
>>
>>
>> When I submit a test job, I get the following error on compute node1003
>> 07/31/2008 15:52:55;0008;   pbs_mom;Job;process_request;request type 
>> CopyFiles from host nona-man allowed
>> 07/31/2008 15:52:55;0008;   pbs_mom;Job;11.nona-man;attempting to copy 
>> file 'nona-man:/home/mef/test3.out'
>> 07/31/2008 15:52:55;0001;   pbs_mom;Svr;pbs_mom;Success (0) in 
>> fork_to_user, cannot find user 'mef' in password file
>> 07/31/2008 15:52:55;0080;   pbs_mom;Req;req_reject;Reject reply 
>> code=15023(Bad UID for job execution REJHOST=node1003 MSG=cannot find 
>> user 'mef' in password file), aux=0, type=CopyFiles, from 
>> PBS_Server at nona-man
>>
>> But I can run ypcat passwd on node1003 and the account mef is listed.  
>> Not sure why I am getting that error.
>>     
>
> The correct test to use is 'getent passwd mef'.  That will tell you if the
> username is visible to the system passwd database.  'ypcat' just tests NIS.
>
>
>
>   

-- 
Thanks
Mary Ellen



More information about the torqueusers mailing list