[torqueusers] mpi libraries not being loaded with torque

James A. Peltier jpeltier at cs.sfu.ca
Mon Sep 10 15:31:15 MDT 2007


Adams, Samuel D Contr AFRL/HEDR wrote:
> I am trying to make my new cluster flexible such that it can run with
> more than one configuration at the same time.  For example, you can
> choose gcc, pg, or Intel compilers using OpenMPI.  To start out with, I
> am just using gcc 4.1 that comes with RHEL5 and OpenMPI.  For some
> reason, I am having trouble with the way it is loading the libraries
> depending on how I run the job.  Basically it would seem that the
> LD_LIBRARY_PATH is not set properly depending one how I run the job; it
> works interactively but not with torque.  
> 
> I have this set in my .bashrc file in the root of my home directory
> 
> if [ `hostname | grep "prod"` ]; then
>         PATH=/usr/local/profiles/gcc-openmpi/bin/:$PATH
>  
> LD_LIBRARY_PATH=/usr/local/profiles/gcc-openmpi/lib/:$LD_LIBRARY_PATH
> fi
> [sam at prodnode1 fdtd_0.3]$ echo "echo $LD_LIBRARY_PATH" | qsub
> 
> And I got, which seems to be what I would expect:
> 
> [sam at prodnode1 fdtd_0.3]$ cat STDIN.o226
> /usr/local/profiles/gcc-openmpi/lib/:
> 

Try with ${PATH} and ${LD_LIBRARY_PATH}.  I would expect to see more 
than just the openmpi paths there.  i.e. /usr/bin /usr/lib etc.

-- 
James A. Peltier
Technical Director, RHCE
SCIRF | GrUVi @ Simon Fraser University - Burnaby Campus
Phone   : 604-291-3610
Fax     : 604-291-3045
Mobile  : 778-840-6434
E-Mail  : jpeltier at cs.sfu.ca
Website : http://gruvi.cs.sfu.ca | http://scirf.cs.sfu.ca
MSN     : subatomic_spam at hotmail.com


More information about the torqueusers mailing list