[torqueusers] qsub: Bad UID for job execution

Gordon Golding gordon.golding at colorado.edu
Mon Oct 29 10:47:19 MDT 2007

>From Troubleshooting pages:

I want to submit and run jobs as root

While this can be a very bad idea from a security point of view, in some
restricted environments this can be quite useful and can be enabled by
setting the acl_roots
arameters#acl_roots>  parameter via qmgr
command as in the following example: 

> qmgr -c 's s acl_roots+=root@*'




From: torqueusers-bounces at supercluster.org
[mailto:torqueusers-bounces at supercluster.org] On Behalf Of Aaron Knister
Sent: Monday, October 29, 2007 8:47 AM
To: bol at CLEMSON.EDU
Cc: torqueusers at supercluster.org
Subject: Re: [torqueusers] qsub: Bad UID for job execution


I believe that by default (and I don't know if you can change this) root
cannot submit jobs to torque.




On Oct 26, 2007, at 8:37 PM, bol at CLEMSON.EDU wrote:



The installation of TORQUE is almost done on my cluster. But when I tried
the command: echo "sleep 30" | qsub , I got error: "qsub: Bad UID for job


I can see the correct information of the compute nodes when I run command:
pbsnodes -a


By the way, the OS of all nodes are CentOS.  I am using root account during
installation and test.


Any suggestion, thanks!


torqueusers mailing list
torqueusers at supercluster.org


Aaron Knister

Associate Systems Administrator/Web Designer

Center for Research on Environment and Water


(301) 595-7001

aaron at iges.org



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20071029/211212d7/attachment-0001.html

More information about the torqueusers mailing list