[torqueusers] No default server name

Kandy Wong kandyw at triumf.ca
Tue Nov 13 14:14:21 MST 2007


Garrick Staples wrote:
> On Thu, Nov 08, 2007 at 04:48:59PM -0800, Kandy Wong alleged:
>   
>> Hi,
>>
>> I've sent email about this problem before but I still can't get it resolved.
>> I've double checked the server_name and pbs_environment are set.
>> I've tried to restart the pbs_server and pbs_mom services.
>> I've also tried to install new rpms for Torque, but still when I tried 
>> the 'qmgr' command, it said:
>> qmgr: cannot connect to server
>> No default server name.
>>
>> I'm using SL4 and the followings are the new rpms that I've installed:
>> torque-docs-2.1.9-4cri.slc4.i386
>> torque-server-2.1.9-4cri.slc4.i386
>> torque-scheduler-2.1.9-4cri.slc4.i386
>> torque-client-2.1.9-4cri.slc4.i386
>> torque-devel-2.1.9-4cri.slc4.i386
>> torque-mom-2.1.9-4cri.slc4.i386
>> torque-2.1.9-4cri.slc4.i386
>> torque-debuginfo-2.1.9-4cri.slc4.i386
>>
>> I have already included the server name 'neut00' in:
>> /var/spool/pbs/pbs_environment
>> /var/spool/pbs/server_name
>> But when I tried to run the 'torque.setup', it also said:
>> qmgr: cannot connect to server
>> No default server name.
>>
>> So I even tried to do 'qmgr neut00', it said:
>> No Permission.
>> qmgr: cannot connect to server neut00
>>
>> But I can execute 'qmgr' from other nodes but I couldn't do any 
>> configurations as it said:
>> Qmgr: set queue work queue_type=Execution
>> qmgr obj=work svr=default: Unauthorized Request
>>
>> So any ideas of what are causing this problem besides setting the 
>> server_name?
>>     
>
> Are you sure /var/spool/pbs is the right directory?  Something like 'rpm -ql
> torque' would be good to check.  Also, could there a second install?  Perhaps a
> source install in /usr/local?
>   
I've found a source install at the following directory:
/usr/src/redhat/BUILD/torque-2.1.8

So should I remove that directory?

The following is the output for 'rpm -ql torque':
[kandy at neut00 ~]# rpm -ql torque
/usr/share/doc/torque-2.1.8
/usr/share/doc/torque-2.1.8/CHANGELOG
/usr/share/doc/torque-2.1.8/INSTALL
/usr/share/doc/torque-2.1.8/PBS_License.txt
/usr/share/doc/torque-2.1.8/README.torque
/usr/share/doc/torque-2.1.8/Release_Notes
/usr/share/doc/torque-2.1.8/torque.setup
/var/torque/aux
/var/torque/pbs_environment
/var/torque/server_name
/var/torque/spool

So the new RPMs that I've got installed Torque at /var/torque/ instead 
of /var/spool/pbs and I've already removed the old RPMs so can I just 
simply remove the 'var/spool/pbs' for fixing the problem?

Thank you very much.

Kandy



More information about the torqueusers mailing list