[torqueusers] No default server name

Garrick Staples garrick at usc.edu
Mon Nov 12 13:10:14 MST 2007


On Thu, Nov 08, 2007 at 04:48:59PM -0800, Kandy Wong alleged:
> Hi,
> 
> I've sent email about this problem before but I still can't get it resolved.
> I've double checked the server_name and pbs_environment are set.
> I've tried to restart the pbs_server and pbs_mom services.
> I've also tried to install new rpms for Torque, but still when I tried 
> the 'qmgr' command, it said:
> qmgr: cannot connect to server
> No default server name.
> 
> I'm using SL4 and the followings are the new rpms that I've installed:
> torque-docs-2.1.9-4cri.slc4.i386
> torque-server-2.1.9-4cri.slc4.i386
> torque-scheduler-2.1.9-4cri.slc4.i386
> torque-client-2.1.9-4cri.slc4.i386
> torque-devel-2.1.9-4cri.slc4.i386
> torque-mom-2.1.9-4cri.slc4.i386
> torque-2.1.9-4cri.slc4.i386
> torque-debuginfo-2.1.9-4cri.slc4.i386
> 
> I have already included the server name 'neut00' in:
> /var/spool/pbs/pbs_environment
> /var/spool/pbs/server_name
> But when I tried to run the 'torque.setup', it also said:
> qmgr: cannot connect to server
> No default server name.
> 
> So I even tried to do 'qmgr neut00', it said:
> No Permission.
> qmgr: cannot connect to server neut00
> 
> But I can execute 'qmgr' from other nodes but I couldn't do any 
> configurations as it said:
> Qmgr: set queue work queue_type=Execution
> qmgr obj=work svr=default: Unauthorized Request
> 
> So any ideas of what are causing this problem besides setting the 
> server_name?

Are you sure /var/spool/pbs is the right directory?  Something like 'rpm -ql
torque' would be good to check.  Also, could there a second install?  Perhaps a
source install in /usr/local?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20071112/4d9c6685/attachment.bin


More information about the torqueusers mailing list