[torqueusers] No default server name

Kandy Wong kandyw at triumf.ca
Fri Nov 9 17:37:12 MST 2007


Hi George,

No, pbs_server is not running on the working nodes.  I only have the
pbs_server on the head node which is neut00.
So when I tried qmgr -c 'print server', the following is the output:
[root at neut00 pbs]# qmgr -c 'print server'
No Permission.
qmgr: cannot connect to server

But then I tried it on a working node, the following is the output:
[kandy at neut07 pbs]$ qmgr -c 'print server'
#
# Set server attributes.
#
set server log_events = 511
set server mail_from = adm
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
set server pbs_version = 2.1.9

But I couldn't set new configuration on the working node as it said:
qmgr obj= svr=default: Unauthorized Request

Kandy

> Hi Kandy,
>
> if I understood well you are running pbs_server on all your working nodes.
> Torque is configured to have mom and server running on the head node
> and mom on each working node.
>
> Probably this is your problem. Try killing all the servers running on
> the working nodes and keeping only the one on your head node. You can
> check the configuration of your server by doing   qmgr -c 'print
> server'  on your head node.
>
> If that is not your problem then it looks like a name resolution.
>
> George
>
> On Nov 8, 2007 7:48 PM, Kandy Wong <kandyw at triumf.ca> wrote:
>> Hi,
>>
>> I've sent email about this problem before but I still can't get it
>> resolved.
>> I've double checked the server_name and pbs_environment are set.
>> I've tried to restart the pbs_server and pbs_mom services.
>> I've also tried to install new rpms for Torque, but still when I tried
>> the 'qmgr' command, it said:
>> qmgr: cannot connect to server
>> No default server name.
>>
>> I'm using SL4 and the followings are the new rpms that I've installed:
>> torque-docs-2.1.9-4cri.slc4.i386
>> torque-server-2.1.9-4cri.slc4.i386
>> torque-scheduler-2.1.9-4cri.slc4.i386
>> torque-client-2.1.9-4cri.slc4.i386
>> torque-devel-2.1.9-4cri.slc4.i386
>> torque-mom-2.1.9-4cri.slc4.i386
>> torque-2.1.9-4cri.slc4.i386
>> torque-debuginfo-2.1.9-4cri.slc4.i386
>>
>> I have already included the server name 'neut00' in:
>> /var/spool/pbs/pbs_environment
>> /var/spool/pbs/server_name
>> But when I tried to run the 'torque.setup', it also said:
>> qmgr: cannot connect to server
>> No default server name.
>>
>> So I even tried to do 'qmgr neut00', it said:
>> No Permission.
>> qmgr: cannot connect to server neut00
>>
>> But I can execute 'qmgr' from other nodes but I couldn't do any
>> configurations as it said:
>> Qmgr: set queue work queue_type=Execution
>> qmgr obj=work svr=default: Unauthorized Request
>>
>> So any ideas of what are causing this problem besides setting the
>> server_name?
>>
>> Kandy
>>
>> _______________________________________________
>> torqueusers mailing list
>> torqueusers at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>
>
>


-- 
Kandy Wong
Scientific Programmer Analyst
TRIUMF (Canada's National Laboratory for Particle and Nuclear Physics)
4004 Wesbrook Mall
Vancouver, BC, Canada, V6T 2A3
Phone: (604) 222- 1047 ext. 6193
Email: kandyw at triumf.ca


More information about the torqueusers mailing list