[torqueusers] Building torque 2.2.1 RPM from spec fails

Garrick Staples garrick at usc.edu
Tue Nov 6 22:16:58 MST 2007


On Tue, Nov 06, 2007 at 08:50:21PM -0800, James A. Peltier alleged:
> Garrick Staples wrote:
> >On Tue, Nov 06, 2007 at 05:15:04PM -0800, James A. Peltier alleged:
> >>Hi All,
> >>
> >>I'm trying to build the Torque 2.2.1 package from the spec provided in 
> >>the tar.gz file on CentOS 5.0.  When I perform a
> >>
> >>rpmbuild --bb SPEC/torque.spec
> >>
> >>in the /usr/src/redhat directory, it decompresses the package and begins 
> >>the configure process but fails with the following error.
> >>
> >>checking for working getgroups... yes
> >>checking for atexit... yes
> >>checking for ntohl... yes
> >>checking for correct TEA configuration... ok
> >>checking for Tcl configuration... configure: error: yes directory 
> >>doesn't contain tclConfig.sh
> >>error: Bad exit status from /var/tmp/rpm-tmp.60144 (%build)
> >>
> >>
> >>RPM build errors:
> >>    parse error in expression
> >>    /usr/src/redhat/SPECS/torque.spec:443: parseExpressionBoolean 
> >>returns -1
> >>    Bad exit status from /var/tmp/rpm-tmp.60144 (%build)
> >>
> >>
> >>It seems to be complaining that it can't find tclConfig.sh which is on 
> >>the system and located in /usr/lib/tclConfig.sh and 
> >>/usr/lib64/tclConfig.sh, and when I run configure manually it completes 
> >>configure just fine.
> >>
> >>Am I missing something bone-headed'ly obvious?
> >
> >I slightly broke --with-tcl.  Remove it from the ./configure line of 
> >torque.spec.
> >
> >
> >------------------------------------------------------------------------
> >
> >_______________________________________________
> >torqueusers mailing list
> >torqueusers at supercluster.org
> >http://www.supercluster.org/mailman/listinfo/torqueusers
> 
> Please see below diff which did not fix the problem.
> 
> diff /tmp/torque-2.2.1/torque.spec /usr/src/redhat/SPECS/torque.spec
> 154c154
> <  %{guiflags} %{syslogflags} %{tclflags} %{rppflags} %{scpflags} 
> %{drmaaflags} \
> ---
> >  %{syslogflags} %{rppflags} %{scpflags} %{drmaaflags} \
> 
> The system now gets to the point of compiling and then fails with the 
> following error.
> 
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> Requires: /bin/sh libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) 
> libc.so.6(GLIBC_2.3)(64bit) libdl.so.2()(64bit) libm.so.6()(64bit) 
> libncurses.so.5()(64bit) libpthread.so.0()(64bit) 
> libreadline.so.5()(64bit) libtcl8.4.so()(64bit) libtorque.so.2()(64bit) 
> rtld(GNU_HASH) torque = 2.2.1-1cri
> Processing files: torque-gui-2.2.1-1cri
> error: File not found: /var/tmp/torque-2.2.1-buildroot/usr/bin/pbs_wish
> error: File not found: /var/tmp/torque-2.2.1-buildroot/usr/bin/xpbs
> error: File not found: /var/tmp/torque-2.2.1-buildroot/usr/bin/xpbsmon
> error: File not found: /var/tmp/torque-2.2.1-buildroot/usr/lib64/xpbs
> error: File not found: /var/tmp/torque-2.2.1-buildroot/usr/lib64/xpbsmon
> Processing files: torque-localhost-2.2.1-1cri
> Processing files: torque-devel-2.2.1-1cri
> Provides: libtorque-devel
> Requires(interp): /bin/sh
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> Requires(pre): /bin/sh
> Requires: /bin/sh libtorque.so.2()(64bit) torque = 2.2.1-1cri
> Processing files: torque-pam-2.2.1-1cri
> Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.64881
> + umask 022
> + cd /usr/src/redhat/BUILD
> + cd torque-2.2.1
> + DOCDIR=/var/tmp/torque-2.2.1-buildroot/usr/share/doc/torque-pam-2.2.1
> + export DOCDIR
> + rm -rf /var/tmp/torque-2.2.1-buildroot/usr/share/doc/torque-pam-2.2.1
> + /bin/mkdir -p 
> /var/tmp/torque-2.2.1-buildroot/usr/share/doc/torque-pam-2.2.1
> + cp -pr src/pam/README.pam 
> /var/tmp/torque-2.2.1-buildroot/usr/share/doc/torque-pam-2.2.1
> + exit 0
> Provides: pam_pbssimpleauth.so()(64bit)
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> Requires: libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) 
> libpam.so.0()(64bit) libpam.so.0(LIBPAM_1.0)(64bit) rtld(GNU_HASH)
> 
> 
> RPM build errors:
>     parse error in expression
>     /usr/src/redhat/SPECS/torque.spec:443: parseExpressionBoolean 
> returns -1
>     File not found: /var/tmp/torque-2.2.1-buildroot/usr/bin/pbs_wish
>     File not found: /var/tmp/torque-2.2.1-buildroot/usr/bin/xpbs
>     File not found: /var/tmp/torque-2.2.1-buildroot/usr/bin/xpbsmon
>     File not found: /var/tmp/torque-2.2.1-buildroot/usr/lib64/xpbs
>     File not found: /var/tmp/torque-2.2.1-buildroot/usr/lib64/xpbsmon

You don't have tk-devel installed on your system.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20071106/bf5a1199/attachment.bin


More information about the torqueusers mailing list