[torqueusers] Building torque 2.2.1 RPM from spec fails

Garrick Staples garrick at usc.edu
Tue Nov 6 18:51:41 MST 2007


On Tue, Nov 06, 2007 at 05:15:04PM -0800, James A. Peltier alleged:
> Hi All,
> 
> I'm trying to build the Torque 2.2.1 package from the spec provided in 
> the tar.gz file on CentOS 5.0.  When I perform a
> 
> rpmbuild --bb SPEC/torque.spec
> 
> in the /usr/src/redhat directory, it decompresses the package and begins 
> the configure process but fails with the following error.
> 
> checking for working getgroups... yes
> checking for atexit... yes
> checking for ntohl... yes
> checking for correct TEA configuration... ok
> checking for Tcl configuration... configure: error: yes directory 
> doesn't contain tclConfig.sh
> error: Bad exit status from /var/tmp/rpm-tmp.60144 (%build)
> 
> 
> RPM build errors:
>     parse error in expression
>     /usr/src/redhat/SPECS/torque.spec:443: parseExpressionBoolean 
> returns -1
>     Bad exit status from /var/tmp/rpm-tmp.60144 (%build)
> 
> 
> It seems to be complaining that it can't find tclConfig.sh which is on 
> the system and located in /usr/lib/tclConfig.sh and 
> /usr/lib64/tclConfig.sh, and when I run configure manually it completes 
> configure just fine.
> 
> Am I missing something bone-headed'ly obvious?

I slightly broke --with-tcl.  Remove it from the ./configure line of torque.spec.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20071106/aae72149/attachment.bin


More information about the torqueusers mailing list