[torqueusers] Building torque 2.2.1 RPM from spec fails

James A. Peltier jpeltier at cs.sfu.ca
Tue Nov 6 18:15:04 MST 2007


Hi All,

I'm trying to build the Torque 2.2.1 package from the spec provided in 
the tar.gz file on CentOS 5.0.  When I perform a

rpmbuild --bb SPEC/torque.spec

in the /usr/src/redhat directory, it decompresses the package and begins 
the configure process but fails with the following error.

checking for working getgroups... yes
checking for atexit... yes
checking for ntohl... yes
checking for correct TEA configuration... ok
checking for Tcl configuration... configure: error: yes directory 
doesn't contain tclConfig.sh
error: Bad exit status from /var/tmp/rpm-tmp.60144 (%build)


RPM build errors:
     parse error in expression
     /usr/src/redhat/SPECS/torque.spec:443: parseExpressionBoolean 
returns -1
     Bad exit status from /var/tmp/rpm-tmp.60144 (%build)


It seems to be complaining that it can't find tclConfig.sh which is on 
the system and located in /usr/lib/tclConfig.sh and 
/usr/lib64/tclConfig.sh, and when I run configure manually it completes 
configure just fine.

Am I missing something bone-headed'ly obvious?

-- 
James A. Peltier
Technical Director, RHCE
SCIRF | GrUVi @ Simon Fraser University - Burnaby Campus
Phone   : 778-782-3610
Fax     : 778-782-3045
Mobile  : 778-840-6434
E-Mail  : jpeltier at cs.sfu.ca
Website : http://gruvi.cs.sfu.ca | http://scirf.cs.sfu.ca
MSN     : subatomic_spam at hotmail.com


More information about the torqueusers mailing list