[torqueusers] qstat -x broken on FC6

Kevin Van Workum vanw at tticluster.com
Tue Mar 27 06:02:28 MDT 2007


I've recently built torque 2.1.6 on a FC6 machine and found that qstat
-x doesn't work correctly, however pbsnodes -x and qstat -f also work
correctly. Does torque use a specific version of some xml library that
might have caused the problem? Any other ideas or suggestions?

Here's the out of qstat -x from my FC6 host:

# /usr/local/torque-2.1.6/bin/qstat -x 4369
<Data><Job>959853364<Job_Name>1229214803</Job_Name><Job_Owner>2003722614</Job_Owner><job_state>82</job_state><queue>1702195556</queue><server>1851878762</server><Checkpoint>117</Checkpoint><ctime>876032305</ctime><Error_Path>979989620</Error_Path><exec_host>1701080942</exec_host><Hold_Types>110</Hold_Types><Join_Path>110</Join_Path><Keep_Files>110</Keep_Files><Mail_Points>97</Mail_Points><mtime>876032305</mtime><Output_Path>979989620</Output_Path><Priority>48</Priority><qtime>876032305</qtime><Rerunable>1702195796</Rerunable><Resource_List>1970420273</Resource_List><Resource_List>49</Resource_List><Resource_List>1970420273</Resource_List><Resource_List>808464433</Resource_List><session_id>809054257</session_id><substate>12852</substate><Variable_List>1599291984</Variable_List><euser>2003722614</euser><egroup>2003722614</egroup><hashname>959853364</hashname><queue_rank>909588787</queue_rank><queue_type>69</queue_type><etime>876032305</etime></Job></Data>

As you can see, all the string values are being printed as longs.


More information about the torqueusers mailing list