[torqueusers] FW: Rpy

Anthony Pemberton A.J.Pemberton at bham.ac.uk
Mon Jun 4 03:37:00 MDT 2007


Dear Torque users,

I got the following problem from one of my users. Does anyone have
experience of this type of problem?

I tried running the test case on a quiet compute node to see if it would
work directly as the user did below on the admin node. There appears to
be a "PATH" error to the R command, but this is difficult to trace in
the qsub environment. Is there a way to diagnose?

Regards,

Tony P.

User query:

Today I tried to submit some new jobs on the cluster.
Everything works fine, excepting R/Rpy.

When I use R in one of my jobs (python scripts) an error message
appears.
I don't get these errors when I run the scripts on the command line
without subq.

For example:

When I start the python Console and I use the following code, no errors.
Also when I put this code in a python file and run this file without
qsub (.py) no errors.
-
from rpy import *
r.library('SparseM')
-

When I put this code in a python file and add it as a job it will give
the following error:
-
Traceback (most recent call last):
  File "testSP.py", line 1, in ?
    import rpy
  File "/usr/lib64/python2.3/site-packages/rpy.py", line 53, in ?
    RVERSION = rpy_tools.get_R_VERSION(RHOME)
  File "/usr/lib64/python2.3/site-packages/rpy_tools.py", line 98, in
get_R_VERSION
    raise RuntimeError("Couldn't execute the R interpreter" +
RuntimeError: Couldn't execute the R interpreter `sh: R: command not
found/bin/R'.
-

It looks like there is someting wrong with the Path to RPY?

My Jobfile includes the following code:
-
#PBS -j oe
cd  "$PBS_O_WORKDIR"
python testSP.py > SP.out
-










-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20070604/3c2fd0a6/attachment.html


More information about the torqueusers mailing list