[torqueusers] qsub -I : termcap or window sizes

Garrick Staples garrick at usc.edu
Fri Jul 20 17:04:13 MDT 2007


On Fri, Jul 20, 2007 at 05:59:21PM -0500, David Corredor alleged:
> torque v.2.1.8
> CentOS5 32bit
> 
>   I'm trying to use "VIM", "less" and other ncurses based tools under 
> an interactive job shell but it seems that my local window's properties 
> are not passed along to the remote node where I'm running interactively. 
> More in particular, if I resize the my window after launching my job, 
> the window size (lines & columns) are not updated remotely.
> 
>   This only happens when running through "qsub -I" and I've tried "qsub 
> -V -I" too. And it happens whether I'm remotely connecting on Linux or 
> Windows (xterm,konsole,gnome console,putty). My /etc/termcap files are 
> all the same through all nodes. The remote TERM is xterm by default, 
> I've tried vt100 and screen with no luck.

qsub doesn't handle resizes.

Your email isn't quite clear if everything is working correctly before
the resize.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20070720/94c66ed0/attachment.bin


More information about the torqueusers mailing list