[torqueusers] Cannot compile torque-2.1.8

Bas van der Vlies basv at sara.nl
Fri Jul 6 10:38:43 MDT 2007


On Jul 6, 2007, at 11:57 AM, Hans Meier wrote:

>
> I've tried to build a Debian package of Torque 2.1.8 with  
> torque_2_deb (1.2.0). Following the manual by Bas, I've unpacked  
> the contents of torque_2_deb into a subdirectory of the source  
> directory of Torque (called "debian") and typed "debian/rules  
> binary". However, the compilation fails with the following error  
> message:
> mkdir .libs
>  gcc -DHAVE_CONFIG_H -I. -I. -I../../src/include -I../../src/ 
> include -DPBS_SERVER_HOME=\"/var/spool/torque\" - 
> D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -MT  
> pam_pbssimpleauth.lo -MD -MP -MF .deps/pam_pbssimpleauth.Tpo -c  
> pam_pbssimpleauth.c  -fPIC -DPIC -o .libs/pam_pbssimpleauth.o
> pam_pbssimpleauth.c:60: error: expected ')' before '*' token
> pam_pbssimpleauth.c:199: error: expected ')' before '*' token
> pam_pbssimpleauth.c:206: error: expected ')' before '*' token
> make[3]: *** [pam_pbssimpleauth.lo] Error 1
> make[3]: Leaving directory `/root/torque-2.1.8/src/pam'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/root/torque-2.1.8/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/root/torque-2.1.8'
> make: *** [build] Error 2
>
> Am I missing something? What could be the cause here - am I really  
> the first one to compile this version of Torque?

I just compiled torque 2.1.8 on my Debian etch system and encountered  
no problems. So which version of debian do you use?

regards,


--
Bas van der Vlies
basv at sara.nl





More information about the torqueusers mailing list