[torqueusers] My TORQUE queue configuration doesn't work well.. where i give a mistake?

Filippo Spiga spiga.filippo at gmail.com
Sun Jan 21 02:27:23 MST 2007


Hi,
  I've configured my torque server with 4 queues, 3 for parallel jobs and 1
for serial jobs. The cluster have 20 nodes, 4 dedicated to serial jobs and
16 interconnected with DOLPHIN for parallel calculus. I've decided to
configure TORQUE with this parameters

#
# Create queues and set their attributes.
#
#
# Create and define queue parallel_short
#
create queue parallel_short
set queue parallel_short queue_type = Execution
set queue parallel_short Priority = 1000
set queue parallel_short resources_max.walltime = 02:00:00
set queue parallel_short enabled = True
set queue parallel_short started = True
#
# Create and define queue parallel_medium
#
create queue parallel_medium
set queue parallel_medium queue_type = Execution
set queue parallel_medium Priority = 100
set queue parallel_medium resources_max.walltime = 08:00:00
set queue parallel_medium resources_min.walltime = 02:00:01
set queue parallel_medium enabled = True
set queue parallel_medium started = True
#
# Create and define queue parallel_long
#
create queue parallel_long
set queue parallel_long queue_type = Execution
set queue parallel_long Priority = 10
set queue parallel_long max_queuable = 10
set queue parallel_long max_running = 2
set queue parallel_long resources_max.walltime = 24:00:00
set queue parallel_long resources_min.walltime = 08:00:01
set queue parallel_long enabled = True
set queue parallel_long started = True
#
# Create and define queue serial_exec
#
create queue serial_exec
set queue serial_exec queue_type = Execution
set queue serial_exec Priority = 1000
set queue serial_exec max_queuable = 25
set queue serial_exec max_running = 8
set queue serial_exec resources_max.nodect = 1
set queue serial_exec resources_max.walltime = 48:00:00
set queue serial_exec enabled = True
set queue serial_exec started = True
#
# Set server attributes.
#
set server scheduling = True
set server default_queue = parallel_short
set server log_events = 511
set server mail_from = adm
set server query_other_jobs = True
set server scheduler_iteration = 120
set server node_check_rate = 150
set server tcp_timeout = 6
set server pbs_version = 2.1.6

Something is wrong?

Best Regards

-- 
Filippo Spiga
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20070121/7dc9f27b/attachment.html


More information about the torqueusers mailing list