[torqueusers] Strange hostname.domain issue with torque on beowulf

Thomas H Dr Pierce TPierce at rohmhaas.com
Fri Jan 12 06:48:04 MST 2007

Dear Torque/Maui Users,

I have been running Torque only for a few weeks, so not all parts work 

All jobs seem to think they are run by  installer at localhost.localdomain . 
"installer" is a loginid that submits a job, but it is submitted to a 
queue on the master node called "silvio" and I do not use localdomain at 
all on the beowulf cluster...

The issue is how to define localhost.localdomain in torque queues? 
hostname returns silvio, dnsdomainname returns nothing as it should.

Jobs do run but they only run on the FIRST node in the nodes lists (only) 
- admittedly only one or two jobs at time and that node can run at least 
If I setup maui, it fails immediately since localhost.localdomain is not 
an authorized node..  I'd like to move up to maui but I have to fix the 
localdomain issue first.

pbsnodes -a 
     state = free
     np = 4
     properties = d1950
     ntype = cluster
     jobs = 0/52.localhost.localdomain       <-------???? 
localhost.localdomain : should be " jobs = 0/52.silvio " ??
     status = opsys=linux,uname=Linux node07 2.6.9-42.ELsmp #1...
     state = free
     np = 2
     ntype = time-shared
     status = opsys=linux,uname=Linux silvio 2.6.9-42.0.3.ELsmp #1..

With the master node seeming to know that its name is "silvio" - and in 
the beowulf cluster there is no DNS domain definition. Good ol' fashioned 
/etc/hosts names 
#       localhost.localdomain  localhost    kickstart    silvio silvio.sh.rohmhaas.com   node07  node7   node08  node8

NB - the silvio.sh.rohmhaas.com is for the other ethernet card to allow 
remote access to the cluster master.

   Tom Pierce
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20070112/5ad2594a/attachment.html

More information about the torqueusers mailing list