[torqueusers] possible bug with pbs clients ?

James Richardson jrichardson at x-iss.com
Wed Feb 21 17:02:58 MST 2007


If you just want to install PBS in a different directory for easier
tar'ing you can:

	./configure --prefix=/usr/local/pbs
	make DESTDIR=/tmp/pbs install


Then tar up /tmp/pbs.

Thanks,

James T. Richardson, Jr.
jrichardson at x-iss.com
eXcellence in IS Solutions, Inc.
713-862-9200 x226


-----Original Message-----
From: torqueusers-bounces at supercluster.org
[mailto:torqueusers-bounces at supercluster.org] On Behalf Of Garrick
Staples
Sent: Wednesday, February 21, 2007 5:46 PM
To: torqueusers at supercluster.org
Subject: Re: [torqueusers] possible bug with pbs clients ?

On Wed, Feb 21, 2007 at 03:36:03PM -0800, Yang Y Yang alleged:
> I compiled torque, with prefix=/mnt/some_dir
> 
> then I tar'ed up the /mnt/some_dir
> and tar'ed it into /mnt/another_dir,
> 
> then I start pbs_server -t create,
> 
> but when I run qmgr, qstat,
> it outputs : 
> "
> No permission.
> qmgr failed to connect to ...
> "
> 
> finally I found that these pbs clients seem to have the address of
> /mnt/some_dir/sbin/pbs_iff hard-coded into them,
> so after I move the src to /mnt/another_dir, 
> they simply fail to work, though I have /mnt/another_dir in my $PATH,
> 
> 
> I copied pbs_iff to /mnt/another_dir/sbin, then it worked,
> should this be considered a bug ?

TORQUE has never been "relocatable" on the filesystem, though you can
set the PBSBINDIR env var and the client libs will find pbs_iff.

_______________________________________________
torqueusers mailing list
torqueusers at supercluster.org
http://www.supercluster.org/mailman/listinfo/torqueusers

NOTICE:
This message may contain privileged or otherwise confidential information.
If you are not the intended recipient, please immediately advise the sender
by reply email and delete the message and any attachments without using,
copying or disclosing the contents.




More information about the torqueusers mailing list