[torqueusers] Problems with qmgr

Thomas Dargel td at chemie.hu-berlin.de
Tue Aug 28 01:22:49 MDT 2007


Hello Saurabh

Saurabh Barve wrote:
> Hello,
> 
> I am trying to set up Torque PBS/Maui system on my cluster, but am running
> into problems.
> 
> Due to a dual-NIC setup, there is a conflict between the hostname on the
> internal network (head: 172.16.100.1) and the one on the external network
> (wilma: 172.20.*.*). As a result the 'qmgr' command returns error messages
> for my commands.
> 

Is 'wilma' (172.20.*.*) associated with the first network-device (eth0) and 
'head' (172.16.100.1) with the second (e.g. eth1)?

Then you should try to start the pbs_server with this extension:

#> pbs_server -S wilma:15004

The entries in /var/torque/server_name

> First of all, here is the info in the files that I find relevant:
> ----------------
> [root at wilma ~]# cat /var/torque/server_name
> head

and /var/torque/torque.cfg (@frontend and @nodes)

> ----------------
> \\\
> ----------------
> [root at wilma ~]# cat /var/torque/torque.cfg
> SERVERHOST head

should be fine.

Please, don't forget to restart 'maui' after you started 'pbs_server',
sometimes this solves a strange behaviour ...

Good luck,

  Thomas.

> ALLOWCOMPUTEHOSTSUBMIT true
> ----------------
> \\\
> ----------------
> [root at wilma ~]# cat /var/torque/server_priv/nodes
> head np=8
> node001 np=4
> node002 np=4
> node003 np=4
> node004 np=4
> ----------------
> \\\
> ----------------
> [root at wilma ~]# cat /var/torque/mom_priv/config
> $pbsserver head
> $logevent 0x1fff
> $usecp  *:/storage /storage
> $rcpcmd /usr/bin/scp -CrBpq
> ----------------
> \\\
> Now when I try to run the 'qmgr' command, I get errors like these:
> ----------------
> Qmgr: set head managers = root
> qmgr: Illegal object type: head
> ...
> Qmgr: active queue batch
> Qmgr: set queue queue_default=batch
> qmgr: Syntax error - cannot locate attribute
> set queue queue_default=batch
>                         ^
> ...
> Qmgr: set server head operators=root
> qmgr obj=head svr=head: Unauthorized Request
> ...
> ----------------
> 
> 
> NOTE: 
> -------
> I suspect that this might be related to a problem I had with 'maui' earlier
> The "SERVERHOST' variable inside maui.cfg was defined as 'head' when the
> system was delivered. When I got an external IP address and hostname for the
> cluster, I had to change the 'SERVERHOST' to 'wilma'.
> 
> 
> Could anyone help me with this problem? It is much appreciated.
> Thanks,
> Saurabh




More information about the torqueusers mailing list