[torqueusers] RE: torqueusers Digest, Vol 37, Issue 6

Ai Niwaer anwar at cse.unl.edu
Sat Aug 4 19:41:05 MDT 2007


>>Peter Wyckoff wrote,
>>   Does anyone have an api for torque in Java?


Please check this. They have java interface for torque.

http://www.g-lambda.net/plus/


Anwar




-----Original Message-----
From: torqueusers-bounces at supercluster.org
[mailto:torqueusers-bounces at supercluster.org] On Behalf Of
torqueusers-request at supercluster.org
Sent: Saturday, August 04, 2007 1:00 PM
To: torqueusers at supercluster.org
Subject: torqueusers Digest, Vol 37, Issue 6

Send torqueusers mailing list submissions to
	torqueusers at supercluster.org

To subscribe or unsubscribe via the World Wide Web, visit
	http://www.supercluster.org/mailman/listinfo/torqueusers
or, via email, send a message with subject or body 'help' to
	torqueusers-request at supercluster.org

You can reach the person managing the list at
	torqueusers-owner at supercluster.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of torqueusers digest..."


Today's Topics:

   1. Qstat exit code 171 (Peter Wyckoff)
   2. Java API to torque - qsub, qstat, qdel, pbsnodes (Peter Wyckoff)
   3. Re: Qstat exit code 171 (Miles O'Neal)
   4. Strange problem in Torque (Peter Wyckoff)
   5. pbs_connect compiling error  (Ai Niwaer)
   6. Re: pbs_connect compiling error (Garrick Staples)
   7. Re: Strange problem in Torque (Garrick Staples)


----------------------------------------------------------------------

Message: 1
Date: Fri, 03 Aug 2007 16:22:02 -0700
From: Peter Wyckoff <wyckoff at yahoo-inc.com>
Subject: [torqueusers] Qstat exit code 171
To: "torqueusers at supercluster.org" <torqueusers at supercluster.org>
Message-ID: <C2D906AA.6A14%wyckoff at yahoo-inc.com>
Content-Type: text/plain;	charset="US-ASCII"


Hi,

I'm trying to find out what this means? Unfortunately, I have only the error
code and not any message qstat printed.

Does anyone know?

Thanks, pete



------------------------------

Message: 2
Date: Fri, 03 Aug 2007 16:22:55 -0700
From: Peter Wyckoff <wyckoff at yahoo-inc.com>
Subject: [torqueusers] Java API to torque - qsub, qstat, qdel,
	pbsnodes
To: "torqueusers at supercluster.org" <torqueusers at supercluster.org>
Message-ID: <C2D906DF.6A16%wyckoff at yahoo-inc.com>
Content-Type: text/plain;	charset="US-ASCII"


Does anyone have an api for torque in Java?

Thanks, pete



------------------------------

Message: 3
Date: Fri, 3 Aug 2007 18:33:00 -0500 (CDT)
From: meo at intrinsity.com (Miles O'Neal)
Subject: Re: [torqueusers] Qstat exit code 171
To: torqueusers at supercluster.org
Message-ID: <20070803233300.43DAC3805A at chuys.eng.intrinsity.com>
Content-Type: text/plain; charset=us-ascii

Peter Wyckoff said...

+I'm trying to find out what this means? Unfortunately, I have only the
error
+code and not any message qstat printed.

I had to figure out the code system just the other day.

If you look in your torque source
directory, in src/include/pbs_error.h ,
you'll find a bunch of error codes.
These get returened to the shel modulo
256.  The integral factor is 58, so

   58 * 256 = 14848
   14848 + 171 = 15019

#define PBSE_BADCRED    15019           /* Invalid Credential in request */


------------------------------

Message: 4
Date: Fri, 03 Aug 2007 18:24:53 -0700
From: Peter Wyckoff <wyckoff at yahoo-inc.com>
Subject: [torqueusers] Strange problem in Torque
To: "torqueusers at supercluster.org" <torqueusers at supercluster.org>
Message-ID: <C2D92375.6A4B%wyckoff at yahoo-inc.com>
Content-Type: text/plain;	charset="US-ASCII"


Last week we were seeing about a third of our cluster's pbs_moms not
trusting the rest of the cluster - i.e., always saying unauthorized request
when a sister mom tried to involve them in a job. See included snippet from
the logs.

We restarted the pbs_server and all the pbs_moms and the problem was
resolved. 

The only thing I can think of is that earlier in the day, we had too many
queues for the default maui (had 18 and the #define says the max is 12) and
maui was having problems. We deleted the queues and restarted maui which
fixed the maui problem. But, could maui have caused torque to get in a bad
state?

Any help would be appreciated.

Thanks, pete


Jul 24 20:12:17 kry1776 pbs_mom: im_request, bad connect from
72.30.63.43:1023 - unauthorized (okclients:
72.30.62.70,72.30.62.72,72.30.62.71,72.30.62.73,72.30.62.75,72.30.62.77,72.3
0.62.79,72.30.62.78,72.30.62.81,72.




------------------------------

Message: 5
Date: Fri, 3 Aug 2007 23:26:23 -0500
From: "Ai Niwaer" <anwar at cse.unl.edu>
Subject: [torqueusers] pbs_connect compiling error 
To: <torqueusers at supercluster.org>
Message-ID: <000001c7d64f$a382b080$87445d81 at cs.unl.edu>
Content-Type: text/plain;	charset="us-ascii"

I have torque 2.1.8 running.

Compiling this code gives me "undefined reference to "pbs_connect" error
message.
How do I compile it? What libs did I miss?


#include "pbs_error.h"
#include "pbs_ifl.h"
#include "portability.h"
#include "mcom.h"
#include "cmds.h"
int main()
{
	int con;
  	struct batch_status *status, *p;
  	struct attrl *attr;
  	con=pbs_connect(NULL);
  	if (con<0)
		{
     		printf("pbs_errno.\n");
		exit(0);
		}
  	status = pbs_statque(con, NULL, NULL, NULL);
  	if (!status){		
     		printf("pbs_errno.\n");
		exit(0);
		}
   	pbs_statfree(status);

}



------------------------------

Message: 6
Date: Fri, 3 Aug 2007 22:44:33 -0700
From: Garrick Staples <garrick at usc.edu>
Subject: Re: [torqueusers] pbs_connect compiling error
To: Ai Niwaer <anwar at cse.unl.edu>
Cc: torqueusers at supercluster.org
Message-ID: <20070804054433.GP8055 at polop.usc.edu>
Content-Type: text/plain; charset="us-ascii"

On Fri, Aug 03, 2007 at 11:26:23PM -0500, Ai Niwaer alleged:
> I have torque 2.1.8 running.
> 
> Compiling this code gives me "undefined reference to "pbs_connect" error
> message.
> How do I compile it? What libs did I miss?

You missed libtorque.  You need to pass -ltorque, and possibly -L and -I
args
depending on your install.


> #include "pbs_error.h"
> #include "pbs_ifl.h"
> #include "portability.h"
> #include "mcom.h"
> #include "cmds.h"

You don't need pbs_error.h, and portability.h, mcom.h, and cmds.h aren't
part
of the public API; so don't include them either.  In addition, your program
needs stdio.h and stdlib.h.

Then use 'pbs-config' to give you the correct cflags and libs.  Once you
have
that, you might use one of the following to build it:

gcc `pbs-config --cflags` `pbs-config --libs` foo.c -o foo

gcc `pbs-config --cflags` -c foo.c
gcc `pbs-config --libs` foo.o -o foo

make CFLAGS=`pbs-config --cflags` LDFLAGS=`pbs-config --libs` foo

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :
http://www.supercluster.org/pipermail/torqueusers/attachments/20070803/eab44
7f0/attachment-0001.bin

------------------------------

Message: 7
Date: Sat, 4 Aug 2007 08:52:50 -0700
From: Garrick Staples <garrick at usc.edu>
Subject: Re: [torqueusers] Strange problem in Torque
To: Peter Wyckoff <wyckoff at yahoo-inc.com>
Cc: "torqueusers at supercluster.org" <torqueusers at supercluster.org>
Message-ID: <20070804155250.GQ8055 at polop.usc.edu>
Content-Type: text/plain; charset="us-ascii"

On Fri, Aug 03, 2007 at 06:24:53PM -0700, Peter Wyckoff alleged:
> 
> Last week we were seeing about a third of our cluster's pbs_moms not
> trusting the rest of the cluster - i.e., always saying unauthorized
request
> when a sister mom tried to involve them in a job. See included snippet
from
> the logs.
> 
> We restarted the pbs_server and all the pbs_moms and the problem was
> resolved. 
> 
> The only thing I can think of is that earlier in the day, we had too many
> queues for the default maui (had 18 and the #define says the max is 12)
and
> maui was having problems. We deleted the queues and restarted maui which
> fixed the maui problem. But, could maui have caused torque to get in a bad
> state?
> 
> Any help would be appreciated.
> 
> Thanks, pete
> 
> 
> Jul 24 20:12:17 kry1776 pbs_mom: im_request, bad connect from
> 72.30.63.43:1023 - unauthorized (okclients:
>
72.30.62.70,72.30.62.72,72.30.62.71,72.30.62.73,72.30.62.75,72.30.62.77,72.3
> 0.62.79,72.30.62.78,72.30.62.81,72.

Just restarting pbs_server is probably enough for this error, and no, maui
probably doesn't have anything to do with it.

What version of torque?  Earlier versions had some bugs with the okclients
list.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :
http://www.supercluster.org/pipermail/torqueusers/attachments/20070804/e053b
f63/attachment-0001.bin

------------------------------

_______________________________________________
torqueusers mailing list
torqueusers at supercluster.org
http://www.supercluster.org/mailman/listinfo/torqueusers


End of torqueusers Digest, Vol 37, Issue 6
******************************************



More information about the torqueusers mailing list