[torqueusers] beginning with torqueu

Standa Kunc standa.kunc at gmail.com
Fri Oct 20 12:22:35 MDT 2006


I have to thank you all, now it works. Just for record:

Using qsub as regular user helped, actually it is written in documentation.

I unset submit_hosts: set server submit_hosts -= localhost

I renamed /var/spool/torque/localhost to /var/spool/torque/server_name


I repaired permissions to pbs_iff file:
---
root at pc-xubuntu:~# ls -l /usr/local/sbin/pbs_iff
-rwxr-xr-x 1 root root 17430 2006-10-18 22:14 /usr/local/sbin/pbs_iff

chown root:root /usr/local/sbin/pbs_iff
chmod 755 /usr/local/sbin/pbs_iff
chmod u+s /usr/local/sbin/pbs_iff

root at pc-xubuntu:~# ls -l /usr/local/sbin/pbs_iff
-rwsr-xr-x 1 root root 17430 2006-10-18 22:14 /usr/local/sbin/pbs_iff


You saved me a lot of time, I thank you one more time.

Best regards
S. Kunc



On 20/10/06, Garrick Staples <garrick at usc.edu> wrote:
> On Fri, Oct 20, 2006 at 12:32:32AM +0200, Standa Kunc alleged:
> > Thank you. Now I am one step further but now I have different problem.
> > I cannot submit job via qsub. This is the error message:
> >
> > root at pc-xubuntu:~/torque-2.1.3# echo "sleep 30" | qsub
> > qsub: Bad UID for job execution
> >
> > My current configuration is:
> >
> > xubuntu distribution, user root is enabled
>
> Can't run jobs as root.  Use a regular user.
>
> > I modified torque.setup to this:
>
> You only need to run torque.setup once.  After that, just make changes
> interactively in qmgr.
>
> > set server submit_hosts = localhost
>
> You don't need this.  Unset it.
>
>
> > root at pc-xubuntu:~/torque-2.1.3# cat /var/spool/torque/localhost
> > localhost
>
> This should be /var/spool/torque/server_name.
>
>
> > User sk at localhost is also server operator and manager but this user
> > does not help:
> > --
> > pbs_iff: file not setuid root, likely misconfigured
> > pbs_iff: cannot connect to pc-xubuntu:15001 - fatal error, errno=13
> > (Permission denied)
> > No Permission.
> > qsub: cannot connect to server pc-xubuntu (errno=15007)
>
> pbs_iff needs to be setuid root and it should have been after the
> install.  How did you install TORQUE?
>
> chown root:root /usr/local/sbin/pbs_iff
> chmod 755 /usr/local/sbin/pbs_iff
> chmod u+s /usr/local/sbin/pbs_iff
>
>
>
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>
>
>


More information about the torqueusers mailing list