[torqueusers] TORQUE 2.1.3 released!

Garrick Staples garrick at clusterresources.com
Fri Oct 13 13:07:26 MDT 2006


On Fri, Oct 13, 2006 at 05:43:01PM +0200, Ronny T. Lampert alleged:
> >pam_pbssimpleauth.c:60: error: syntax error before '*' token
> >pam_pbssimpleauth.c: In function 'pam_sm_authenticate':
> >pam_pbssimpleauth.c:63: error: 'PAM_SERVICE_ERR' undeclared (first use 
> >
> >Do I need a "-devel" RPM ?
> 
> very much looks like you are missing the pam-devel rpm!

Indeed, this is because of missing libpam0-devel rpm on Mandrake.

Note that the spec file inside of the tarball is intentionally missing
proper BuildRequires because these packages have different names on
different distros.  I've tried to be as "distro agnostic" as possible,
but that also means 90%-correctness on any distro.

It is still my position that the best packaging for any piece of
software is the one that comes with the distro.  I maintain Fedora
packages in Fedora Extras.  Rocks has their own packages, gentoo has
their own, trasz maintains fbsd ports, etc.

I see that Mandriva cooker contrib has TORQUE 2.0.0, so you might want
to bug the maintainer (Oden Eriksson <oeriksson at mandriva.com>) to
update.



More information about the torqueusers mailing list