[torqueusers] Problem on SGI ALTIX

Seb Seb sebast2600 at yahoo.fr
Mon Mar 13 12:42:11 MST 2006


Dear konnipati murali,
   
  I have also an Altix SGI here, and everything is fine. Maybe you should try to add the following lines (for 24 cpus and 47 GB mem):
   
  # Set server attributes.
#
set server scheduling = True
set server managers = root at name.edu
set server operators = root at name.edu
set server default_queue = batch
set server log_events = 511
set server mail_from = adm
set server query_other_jobs = True
set server resources_available.ncpus = 24
set server resources_max.mem = 48128mb
set server resources_max.ncpus = 24
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
   
  And this is how I setup the queues, for exemple:
   
  # Create and define queue medium1
#
create queue medium1
set queue medium1 queue_type = Execution
set queue medium1 resources_max.cput = 10000:00:00
set queue medium1 resources_max.mem = 6144mb
set queue medium1 resources_max.ncpus = 4
set queue medium1 resources_max.walltime = 10000:00:00
set queue medium1 resources_default.cput = 10000:00:00
set queue medium1 enabled = True
set queue medium1 started = True

  If this doesn't solve your problem, try to install Maui. I had many weird problems with the Torque scheduler.
   
  Best regards,
  Seb
  
konnipati murali <munnu_k_mm at yahoo.com> a écrit :
    Dear All,

           I installed  torque-2.0.0p8 on SGI ALTIX system having 24 processors and 48 GB main memory with 2.4.21-sgi306r6  linux kernel. On the same system i am running pbs_mom,pbs_server and pbs_sched dameons.

After installed of torque i followed the procedure given in the below site,..

set server operators = gypse at tropica.npsf.cdac.ernet.in
set server operators += username at headnode
create queue batch
set queue batch queue_type = Execution
set queue batch started = True
set queue batch enabled = True
set server default_queue = batch
set server resources_default.nodes = 1
set server scheduling = True
 
and the folloiwng in the PBS_HOME/server_priv/nodes file

tropica np=24

and in the "config" file in mom_priv directory..

$pbsserver    tropica
$logeven       255

For pbsnodes -a command it is giving following output...

tropica
     state = free
     np = 24
     ntype = cluster
     status = opsys=linux,uname=Linux tropica 2.4.21-sgi306r6 #1 SMP Sat Jun 18 14:43:35 PDT 2005 ia64,sessions=10081 10082 10156 10157 10228 10229 10349 10350 11615 11616 11683 23491 23492 23544 32554 30330 19015 19210 15908 15909 20020 20586 22285 22820 23599 24203 25104 27253 30321 631 632 1066 2993 16194 16876 16877 17035 18154,nsessions=38,nusers=7,idletime=815,totmem=57032064kb,availmem=47283360kb,physmem=47817120kb,ncpus=24,loadave=18.03,netload=58625717438,state=free,jobs=? 15201,rectime=1142243975


But my problem is with the scheduling. I have 24 processor system. When i submit a 24 processor job and after 2 minutes when i submit another 24 processors job. Ide ally, PBS has to put the second job in the Queue. But in my case, when i checked with "qstat" command,for both the jobs it is showing "R" in the status column. 

Then i tried to submit three 24 processors jobs continuously. Then it is showing all the jobs in the Running mode and when i checked with the top command. on each processors it is running more than 2 process.

Is there any problem with the configuration in my installation...Can any body please help me in this regard,

Thanking you in advance,

Yours sincerely,


Murali Krishna Konnipati.
C-DAC,Pune.
India.

Can anybody




    
---------------------------------
  Yahoo! Mail
Use Photomail to share photos without annoying attachments._______________________________________________
torqueusers mailing list
torqueusers at supercluster.org
http://www.supercluster.org/mailman/listinfo/torqueusers


		
---------------------------------
 Nouveau : téléphonez moins cher avec Yahoo! Messenger ! Découvez les tarifs exceptionnels pour appeler la France et l'international.Téléchargez la version beta.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20060313/e52e885b/attachment.html


More information about the torqueusers mailing list