[torqueusers] I have a question about multiqueue with multigroup

?? ? schsue01 at msn.com
Tue Jun 27 19:49:59 MDT 2006


Hi:

My environment is Torque/Maui. I setup five queues. They are list below:
Queue        Type
Route :       Route
R-1 :           Execution
R-2:            Execution
R-3:            Execution
R-4:            Execution

For R-1, I set acl_group with group1. It means only group1's member can use.
For R-2, I set acl_group with group2. It means only group2's member can use.
For R-3, I did not set any restriction.
For R-4, I set acl_user with two users. It means only this two users can 
use.

All setting can work correctly except R-2. Group2' member cannot submit the 
job
to R-2. It always get the Unauth Request error message. I use the same 
setting as
R-1. Why it cannot work? Do I miss something? Below is my setting:


---------------------------------------------------------
#
# Create queues and set their attributes.
#
#
# Create and define queue R-2
#
create queue R-2
set queue R-2 queue_type = Execution
set queue R-2 acl_user_enable = True
set queue R-2 acl_users = johnson
set queue R-2 acl_group_enable = True
set queue R-2 acl_groups = group2
set queue R-2 enabled = True
set queue R-2 started = True
#
# Create and define queue R-1
#
create queue R-1
set queue R-1 queue_type = Execution
set queue R-1 acl_group_enable = True
set queue R-1 acl_groups = group1
set queue R-1 enabled = True
set queue R-1 started = True
#
# Create and define queue route
#
create queue route
set queue route queue_type = Route
set queue route route_destinations = R-1
set queue route route_destinations += R-2
set queue route route_destinations += R-3
set queue route enabled = True
set queue route started = True
#
# Create and define queue R-3
#
create queue R-3
set queue R-3 queue_type = Execution
set queue R-3 enabled = True
set queue R-3 started = True
#
# Set server attributes.
#
set server operators = root at cust-a.cluster
set server default_queue = route
set server log_events = 511
set server mail_from = adm
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
set server pbs_version = 2.1.1

-----------------------------------------------------------


Please help. Thanks.




More information about the torqueusers mailing list