[torqueusers] Problems in integrating Torque and Maui

Giang Trần gavintran at gmail.com
Thu Jun 15 20:12:49 MDT 2006


> > Next,
> >
> > #make
> > #make install
> >
> > To start Maui i run
> >
> > # /usr/local/maui/sbin/maui
> >
> > But it poured out a lot of erros , below is a part of it (I attached a
> > full erros log)
> >
> > ------------------------
> > MFULock(/usr/local/maui/,/usr/local/maui/maui.pid)
> > cannot open lockfile: Permission denied
> > ERROR:    cannot open lockfile '/usr/local/maui/maui.pid', errno: 13
> > (Permission denied)
> > ERROR:    scheduler is already running  (cannot obtain lock on file
> > '/usr/local/maui/maui.pid')
> > INFO:     parent is exiting
> > --------------------
> >
> > I have checked that there's no other process of old maui running.
> >
> > Actually, I have try to install many copies of Maui from p13 to p16
> > ,even with snapshot.
> > Each time I started to install a new one I run
> >
> > # make uninstall
> > # make clean
> > from the previously installed Maui directory
> > I also rm -rf /usr/local/maui
>
> Which OS is this?  All maui is trying to do at this point is open the
> lockfile (it's not even tried to lock it yet).
>
> Is /usr/local NFS mounted?  Any strange mount options?  What are the
> permissions on /usr/local/maui?  Are you using a non-priviledged user
> for maui?

You're right. /usr/local/maui is under permission of root, so I
couldn't start it with non-privileged user. I have chmoded it to user
admin of Maui and get it up ok. But another problem popped up.
When I try to queue a job , like
# echo "sleep 10" | qsub
#qstat
Job id              Name             User             Time Use S Queue
------------------- ---------------- ---------------- -------- - -----
4.aka-server        STDIN            jishin                  0 Q batch

Status is Q ,not R even after a long time later. That means I my job
couldn't be executed on compute nodes.
When I which into pbs_sched , it's ok and show the status of R and
disappeared after 10 seconds.

Does it mean that Maui is still not integrated with Torque ?
Any ideas about this problem ?
Thanks in advance.

My environment : Debian Sarge 3.1 , Torque 2.1p0 , Maui 3.2.6p16


More information about the torqueusers mailing list