[torqueusers] torque 2.1.0p0

Sam Rash srash at yahoo-inc.com
Thu Jun 15 12:29:38 MDT 2006


Hi,


I recently built torque 2.1.0p0 on FreeBSD without any problems.  However,
in running the new pbs_sched daemon, I see a seg fault periodically.  Here
is the tail of an strace:

 

fcntl(7, F_GETFL)                       = 0x2 (flags O_RDWR)

read(7, "+2+1+0+0+9+1+1+0+0+0", 65536)  = 20

write(7, "+2+12+11+9Scheduler+2+22+384513."..., 124) = 124

poll([{fd=7, events=POLLIN|POLLHUP, revents=POLLIN}], 1, 20000) = 1

fcntl(7, F_GETFL)                       = 0x2 (flags O_RDWR)

read(7, "+2+1+0+0+1", 65536)            = 10

write(7, "+2+12+15+9Scheduler2+384513.medi"..., 67) = 67

poll([{fd=7, events=POLLIN|POLLHUP, revents=POLLIN}], 1, 20000) = 1

fcntl(7, F_GETFL)                       = 0x2 (flags O_RDWR)

read(7, "+2+1+0+0+1", 65536)            = 10

gettimeofday({1150395690, 529624}, NULL) = 0

write(3, "06/15/2006 11:21:30;0040; pbs_sc"..., 87) = 87

write(7, "+2+12+24+9Scheduler+0+1+7nodes=1"..., 34) = 34

poll([{fd=7, events=POLLIN|POLLHUP, revents=POLLIN}], 1, 20000) = 1

fcntl(7, F_GETFL)                       = 0x2 (flags O_RDWR)

read(7, "+2+1+0+0+1", 65536)            = 10

--- SIGSEGV (Segmentation fault) ---

--- SIGSEGV (Segmentation fault) ---

--- 139 (Unknown signal: 139) ---

PIOCRUN: Inappropriate ioctl for device

 

 

I can generate more on the matter, but does this problem look at all
familiar to anyone?  (either on freebsd or any other system).

The previous torque build, 2.0.8p16  (I think that's the right #) worked
fine.

 

Thanks in advance,

 

Sam Rash

srash at yahoo-inc.com

408-349-7312

vertigosr37

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20060615/cc925e62/attachment.html


More information about the torqueusers mailing list