[torqueusers] Problems in integrating Torque and Maui

garrick at speculation.org garrick at speculation.org
Mon Jun 12 13:34:55 MDT 2006


On Fri, Jun 09, 2006 at 05:11:25PM +0900, Giang Tr???n alleged:
> configure: WARNING: Resource Manager not specified - attempting build with 
> pbs
> 
> Is it normal or not ?

It is normal if you don't specify a resource manager to configure.  maui
supports many RMs, not just forms of PBS.

 
> Next,
> 
> #make
> #make install
> 
> To start Maui i run
> 
> # /usr/local/maui/sbin/maui
> 
> But it poured out a lot of erros , below is a part of it (I attached a
> full erros log)
> 
> ------------------------
> MFULock(/usr/local/maui/,/usr/local/maui/maui.pid)
> cannot open lockfile: Permission denied
> ERROR:    cannot open lockfile '/usr/local/maui/maui.pid', errno: 13
> (Permission denied)
> ERROR:    scheduler is already running  (cannot obtain lock on file
> '/usr/local/maui/maui.pid')
> INFO:     parent is exiting
> --------------------
> 
> I have checked that there's no other process of old maui running.
> 
> Actually, I have try to install many copies of Maui from p13 to p16
> ,even with snapshot.
> Each time I started to install a new one I run
> 
> # make uninstall
> # make clean
> from the previously installed Maui directory
> I also rm -rf /usr/local/maui

Which OS is this?  All maui is trying to do at this point is open the
lockfile (it's not even tried to lock it yet).

Is /usr/local NFS mounted?  Any strange mount options?  What are the
permissions on /usr/local/maui?  Are you using a non-priviledged user
for maui?




More information about the torqueusers mailing list