[torqueusers] client commands from another system permission denied

Steven A. DuChene linux-clusters at mindspring.com
Thu Jan 26 00:09:41 MST 2006


Thanks for the information. I think I tried the "-q @mgt" thing but I will double
check tomorrow.
The default server is set on the remote machine so the simple "qsub myjob.pbs"
should have worked but I had not set the SUBMITHOSTS piece when I initially
tried this.

-----Original Message-----
>From: Garrick Staples <garrick at usc.edu>
>Sent: Jan 25, 2006 9:13 PM
>To: torqueusers <torqueusers at supercluster.org>
>Subject: Re: [torqueusers] client commands from another system permission	denied
>
>On Wed, Jan 25, 2006 at 06:14:55PM -0500, Steven A. DuChene alleged:
>> I am attempting to install the pbs client commands on a couple
>> of other systems in our cluster but when I execute the following from
>> one of those remote systems:
>> 
>> qsub myjob.pbs
>> 
>> or
>> 
>> qsub -q mgt myjob.pbs   (where mgt is the internal cluster name for the
>>                                         system where the pbs_server process actually runs)
>
>If the server name is mgt, then that should be " -q @mgt".
>
>"-q mgt" refers to a queue named mgt.  "-q q1 at mgt" refers to the q1
>queue on server mgt.
>
> 
>> I am thinking on the management node where the pbs_server
>> process is running I need to put a torque.cfg file into place with
>> the following contents:
>> 
>> SUBMITHOSTS    remotehost1.cluster,remotehost2.cluster
>
>Note there is a bug in the SUBMITHOSTS implementation fixed in 2.0.0p6
>snapshots.  2.0.0p5 and earlier can corrupt memory if the supplied
>hostname is a FQDN.
>
>-- 
>Garrick Staples, Linux/HPCC Administrator
>University of Southern California



More information about the torqueusers mailing list