[torqueusers] Compiling xpbsmon

Bisbal, Prentice PBisbal at LexPharma.com
Mon Jan 23 08:13:32 MST 2006


Diego, 

I don't know which 64-bit distro your using, but I've found the problems on Red Hat Enterprise Linux 3, Update 6 that will prevent xpbsmon from compiling. The first is that symbolic links in /usr/lib64 and /usr/lib are missing for libtkx. There should be sym links named libtks.so that point to libtkx<version>.so in each directory. This can easily be fixed by doing this as root:

cd /usr/lib64
ln -s libtkx8.3.so libtkx.so
cd /usr/lib/
ln -s libtkx8.3.so libtkx.so

This also needs to be done for the .a static libs. 

But this still won't fix the configure script not finding libX11. This is a problem with the configure script. Fortunately this can easily be fixed during configuration by specifying 

--x-libraries=/usr/X11R6/lib64

Doing both these steps, I was able to get TORQUE (again, I compiled everything at once), on RHEL3U6/AMD64.

Prentice Bisbal
Unix Administrator
Lexicon Pharmaceuticals
350 Carter Road 
Princeton NJ, 08540
pbisbal at lexpharma.com
609-466-5578



-----Original Message-----
From: Diego Vadell [mailto:dvadell at lantech.com.ar]
Sent: Fri 1/20/2006 11:13 AM
To: Bisbal, Prentice
Cc: torqueusers at supercluster.org
Subject: RE: [torqueusers] Compiling xpbsmon
 
Hi,
  I tried setting tcldir and tclxdir ( I assume you are talking about

  --with-tcl=DIR_PREFIX   Use this if you want Tcl support. If you are
                          compiling with tclx then you need only use
                          the --with-tcl flag if the Tcl libraries
                          are in a different place than the tclx
  --with-tclx=DIR_PREFIX  Use this if you want TclX support. This implies
                          --with-tcl. The only time it is useful
                          "tcl" the server will use a Tcl based scheduler

when you tell me tclx_dir=no, but tclx_dir=no is just part of the
configure script I pasted in my last mail.

-----------------8<----------------------8<----------------------
./configure --prefix=/tmp/pbs-temp  \
   --set-server-home=/tmp/pbs-temp/spool/PBS --with-tclx \
   --with-tclx=/usr/lib64 --with-tcl=/usr/lib64
loading cache ./config.cache
checking host system type... x86_64-unknown-linux-gnu
checking Tcl version... notfound
configure: error: cannot find Tcl version in /dev/null
-----------------8<----------------------8<----------------------

If I try --with-tcl[x]=/usr I get the same first error, "/usr/bin/ld:
cannot find -ltkx". This is sane because without specifying where tcl/tclx
is, configure finds it (the 32bit version) in /usr.

LD_LIBRARY_PATH, afaik, is a run-time linker env variable, not a
compile-time linker one. However, I tried, and it gives the same errors.

Regards,
 -- Diego.

<quote who="Bisbal, Prentice">
> Diego,
>
> Have you tried setting your LD_LIBRARY_PATH so /usr/lib64 and /lib64
> come before /usr/lib and /lib before configuring? I assume it should
> already be setup correctly, but you never know.
>
> Also, does "tclx_dir=no" mean that you didn't specify the location of
> your tclx dir in your configure command?
>
> When I compiled TORQUE, I made sure I specified both tcldir and tclxdir
>
> Prentice
>
> -----Original Message-----
> From: torqueusers-bounces at supercluster.org
> [mailto:torqueusers-bounces at supercluster.org] On Behalf Of Diego Vadell
> Sent: Friday, January 20, 2006 8:32 AM
> To: torqueusers at supercluster.org
> Subject: RE: [torqueusers] Compiling xpbsmon
>
> Hi,
>    Answering Garrick, I have both i386 and x86_64 tclx libraries. I
> uninstalled the i386 tclx one, and now configure says:
>
> creating cache ./config.cache
> checking host system type... x86_64-unknown-linux-gnu
> checking Tclx library path prefix... no
> configure: error: could not find the Tclx library
>
> Inside configure, it says:
>
> -----------------8<----------------------8<----------------------
> tclx_dir=no
> ac_LL_PATH=`echo "$PATH" | sed -e 's/:/ /g'`
> for ac_libpath in $ac_LL_PATH /__XqqFrobozz ; do
>     ac_libpath=`echo $ac_libpath | sed -e 's;/bin$;;'`
>     if test `/bin/ls ${ac_libpath}/lib/libtclx*.* 2> /dev/null | wc -l`
> -gt 0; then
>         tclx_dir="$ac_libpath"
>         break;
>     fi
> done
> -----------------8<----------------------8<----------------------
>
> Its making ls $ac_libpath/lib and not giving a chance to /usr/lib64 .
>
> Thats the situation here. Hope it helps a little
>
>  -- Diego.
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20060123/ed52a216/attachment.html


More information about the torqueusers mailing list