[torqueusers] Small problems using Torque + MAUI (start delay, error message, redirecting standard output)

Francesco Del Citto del.citto at ing.uniroma2.it
Fri Jan 20 08:59:01 MST 2006


I've added the line 'set server scheduling = true" and the delay has
desappeared! Thank you!
I have a small cluster, so reducing the poll interval should be not a
problem, but it is unnecessary, now.
What about the message "'unknown': I need something more specific." when
exiting from an interactive session?
As an example, this is what happens:
--------------------------------
[francesco at epsilon ~]$ qsub -I
qsub: waiting for job 1783.epsilon to start
qsub: job 1783.epsilon ready
[francesco at node6 ~]$ top
'unknown': I need something more specific.
[francesco at node6 ~]$ exit
logout
'unknown': I need something more specific.

qsub: job 1783.epsilon completed
[francesco at epsilon ~]$
--------------------------------

I guess it's something related to the terminal, but how can I resove the
problem?
Francesco

Dave Jackson ha scritto:

>Francesco,
>
>  Moab/Maui use both polling and event driven interfaces to manage job
>scheduling.  First off, if your cluster is smaller than 200 nodes, you
>should have no problem reducing your poll interval to 10 seconds or
>lower.
>
>  Secondly, Moab/Maui can load info using TORQUE's event interface.  In
>qmgr, make certain that the line 'set server scheduling' is set to true.
>This enables TORQUE to send events to the scheduler.  When the scheduler
>detects this info, it immediately reloads workload info and attempts to
>schedule.
>
>  Please let us know if this addresses your issues.
>
>Dave
>
>On Mon, 2006-01-16 at 15:51 +0100, Francesco Del Citto wrote:
>  
>
>>Dear Torque users,
>>I'm happly using Torque (2.0.0p0) and MAUI (3.2.6p13) on a linux cluster
>>(Fedora Core 3 - kernel 2.6.11), but I have some question:
>>
>>1)
>>A problem I've encountered is a uncomfortable delay from when a job is
>>submited to whe it starts.
>>The delay varies more or less between 1 to 30 seconds, and I guess it's
>>related to the line
>>RMPOLLINTERVAL        00:00:30
>>in maui.cfg, but it was the suggested value for maui, so I haven't
>>changed it.
>>How can I reduce this delay?
>>
>>2)
>>Another problem I get is a message when exiting from an interactive job:
>><<
>>[francesco at node3 ~]$ exit
>>logout
>>'unknown': I need something more specific.
>>    
>>
>>What does it mean?
>>
>>3)
>>The last problem I've encountered is while redirecting the standard
>>output of a program to a file.
>>A command line like
>>"mpiexec program_to_execute > filelog.out 2>&1"
>>doesn't always works. With some executable it redirects all the output
>>to the file named filelog.out, while with other ones it redirects only
>>the output of mpiexec, if it has any.
>>This happens both in interactive mode and in batch mode.
>>If it could be useful, I get the problem with a self made application
>>written in Fortran95 and compiled with the Intel Fortran Compiler 9.
>>Any suggestions?
>>
>>Thank you very much for your patience!
>>Francesco
>>
>>_______________________________________________
>>torqueusers mailing list
>>torqueusers at supercluster.org
>>http://www.supercluster.org/mailman/listinfo/torqueusers
>>    
>>
>
>
>  
>



More information about the torqueusers mailing list