[torqueusers] Compiling xpbsmon

Garrick Staples garrick at usc.edu
Thu Jan 12 13:11:08 MST 2006


On Wed, Jan 11, 2006 at 03:05:13PM -0300, Diego Vadell alleged:
> Hi all,
>    I was asked to install xpbsmon. We use Rocks and xpbsmon does not come
> with it, so I downloaded torque's sources. My idea was to compile all
> torque and then only install xpbsmon, but however I run ./configure,
> xpbsmon does not get compiled or installed. I tried with
> 
> ./configure --prefix=/tmp/pbs-temp \
> --set-server-home=/tmp/pbs-temp/spool/PBS \
>             --with-tclx
> 
> But when I run make and make install, xpbsmon does not get installed in
> /tmp/pbs-temp . I tried also adding --enable-clients and --with-gui,
> although I read that they were defaults. No sign of in configure's output
> that could tell me that tcl or tclx has been disabled.
> I went to src/tools and ran make and make install there, and it worked
> (with some minor glitches). xpbsmon *is* running now, but it let me with a
> bad taste in my mouth... is there an easier way of compiling torque
> including xpbsmon? Is it that xpbsmon is no longer an active part of
> torque (i.e. nobody is using it and nobody complains when it breaks)? Are
> there any instructions?
> 
> I was using torque-1.2.0p6 in an x86_64 machine.

The configure script doesn't find the tcl/tk libs on x86_64 machines.

But xpbsmon sucks anyways.  It is definitely not maintained anymore.
There are also reports of it breaking on newer TCL versions.  

Use pbstop instead :)

-- 
Garrick Staples, Linux/HPCC Administrator
University of Southern California
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20060112/14f57a0c/attachment.bin


More information about the torqueusers mailing list