[torqueusers] Compiling xpbsmon

Bisbal, Prentice PBisbal at LexPharma.com
Thu Jan 12 12:59:43 MST 2006


I had a similar problem. Make sure you have the correct libraries
(libtcl and libtclx) in the correct location. Also check that you have
the correct header files (tcl.h and tclExtend.h). 

I believe that configure assumes they're in /usr/local. On my Red Hat
they're in /usr, so I configured with

--with-tcl=/usr --with-tclx=/usr

Prentice 

-----Original Message-----
From: Diego M. Vadell [mailto:dvadell at lantech.com.ar] 
Sent: Thursday, January 12, 2006 2:26 PM
To: Bisbal, Prentice; torqueusers at supercluster.org
Subject: Re: [torqueusers] Compiling xpbsmon

Hi,
   Thanks Prentice for the answer. For the record, it was my fault: I
only 
tried --with-tcl  and not --with-tclx. Trying --with-tclx gives me a
compile 
failure. I may have something wrong with my tcl/tk installation.

Thanks again,
 -- Diego.

On Thursday 12 January 2006 16:18, you wrote:
> I had no problem getting xpbs and xpbsmon to compile and install on my
> systems (once I had all the correct tcl/tk dev libraries installed on
my
> systems, that is).
>
> >From the crudeness of the interface, I get the impression that
>
> xpbs/xpbsmon are no longer actively developed.
>
> Prentice
>
> -----Original Message-----
> From: torqueusers-bounces at supercluster.org
> [mailto:torqueusers-bounces at supercluster.org] On Behalf Of Diego
Vadell
> Sent: Wednesday, January 11, 2006 1:05 PM
> To: torqueusers at supercluster.org
> Subject: [torqueusers] Compiling xpbsmon
>
> Hi all,
>    I was asked to install xpbsmon. We use Rocks and xpbsmon does not
> come
> with it, so I downloaded torque's sources. My idea was to compile all
> torque and then only install xpbsmon, but however I run ./configure,
> xpbsmon does not get compiled or installed. I tried with
>
> ./configure --prefix=/tmp/pbs-temp \
> --set-server-home=/tmp/pbs-temp/spool/PBS \
>             --with-tclx
>
> But when I run make and make install, xpbsmon does not get installed
in
> /tmp/pbs-temp . I tried also adding --enable-clients and --with-gui,
> although I read that they were defaults. No sign of in configure's
> output
> that could tell me that tcl or tclx has been disabled.
> I went to src/tools and ran make and make install there, and it worked
> (with some minor glitches). xpbsmon *is* running now, but it let me
with
> a
> bad taste in my mouth... is there an easier way of compiling torque
> including xpbsmon? Is it that xpbsmon is no longer an active part of
> torque (i.e. nobody is using it and nobody complains when it breaks)?
> Are
> there any instructions?
>
> I was using torque-1.2.0p6 in an x86_64 machine.
>
> Thanks in advance,
>  -- Diego.
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers



More information about the torqueusers mailing list