[torqueusers] problem with Altix compile

Steve Young chemadm at hamilton.edu
Wed Jan 4 09:37:49 MST 2006


Yes it is looking like the last upgrade has messed up all 3 of my
Altix's. As Garrick states my C headers are broken. I have tried to
compile some other programs that I know should work and they have
troubles too. I am going to try to re-install some of these packages to
see if it resolves my issue otherwise I'll be logging a case with
SGI :). Thanks again for the help. 

-Steve


On Tue, 2006-01-03 at 12:19 -0800, Garrick Staples wrote:
> On Tue, Jan 03, 2006 at 02:13:10PM -0600, Kevin McMahon alleged:
> >    From your error message, this looks to be a problem with the
> > directory log_directory.
> > 
> >  >   pbs_log.c:114: storage size of `log_directory' isn't known
> > 
> > 
> >    Perhaps there is an issue running as root on a crossmounted 
> > file system?  Usually, root is not allowed to exercise root privileged
> > file operations on such a file system.
> 
> If you look at that line, you'll see that log_directory is a char array:
>   char log_directory[_POSIX_PATH_MAX/2];
> 
> The storage size isn't known because his system C headers are messed up.
> 
> Note below that /usr/include/linux/errno.h seems to be missing.
> 
>  
> > > Jeroen,
> > > 	Well so far I still haven't gotten this to work. I tried the other
> > > example of switching the os_defines.h and I get an error right away:
> > > 
> > > Making all in Libattr
> > > make[3]: Entering directory `/usr/local/src/Original/torque-2.0.0p4-
> > > altix/src/lib/Libattr'make[4]: Entering directory
> > > `/usr/local/src/Original/torque-2.0.0p4-altix/src/lib/Libattr'gcc -g -
> > > I../../../src/include -I../../../src/include -DHAVE_CONFIG_H -c
> > > uLTostr.c
> > > In file included from /usr/include/errno.h:36,
> > >                  from ../../../src/include/Long_.h:85,
> > >                  from uLTostr.c:84:
> > > /usr/include/bits/errno.h:25:26: linux/errno.h: No such file or
> > > directory
> > > uLTostr.c: In function `uLTostr':
> > > uLTostr.c:116: `EDOM' undeclared (first use in this function)
> > > uLTostr.c:116: (Each undeclared identifier is reported only once
> > > uLTostr.c:116: for each function it appears in.)
> > > make[4]: *** [uLTostr.o] Error 1
> > > make[4]: Leaving directory `/usr/local/src/Original/torque-2.0.0p4-
> > > altix/src/lib/Libattr'
> > > make[3]: *** [all] Error 2
> > > make[3]: Leaving directory `/usr/local/src/Original/torque-2.0.0p4-
> > > altix/src/lib/Libattr'
> > > make[2]: *** [all] Error 2
> > > make[2]: Leaving directory `/usr/local/src/Original/torque-2.0.0p4-
> > > altix/src/lib'
> > > make[1]: *** [all] Error 2
> > > make[1]: Leaving directory `/usr/local/src/Original/torque-2.0.0p4-
> > > altix/src'
> > > make: *** [all] Error 2
> > > [root at kilburn torque-2.0.0p4-altix]#
> > > 
> > > 
> > > When I look for the packages mentioned it looks like I do have them:
> > > 
> > > [root at kilburn torque-2.0.0p4-altix]# rpm -qa | grep gcc
> > > gcc-ssa-3.5ssa-0.20030801.48
> > > libgcc-3.2.3-47
> > > libgcc-ssa-3.5ssa-0.20030801.48
> > > libgcc-3.2.3-47
> > > compat-gcc-g77-7.3-2.96.128
> > > gcc-gnat-3.2.3-47
> > > compat-gcc-c++-7.3-2.96.128
> > > gcc-objc-3.2.3-47
> > > gcc-c++-ssa-3.5ssa-0.20030801.48
> > > compat-gcc-c++-7.3-2.96.128
> > > gcc-g77-ssa-3.5ssa-0.20030801.48
> > > gcc-java-ssa-3.5ssa-0.20030801.48
> > > compat-gcc-objc-7.3-2.96.128
> > > gcc-objc-ssa-3.5ssa-0.20030801.48
> > > gcc-c++-3.2.3-47
> > > gcc-java-3.2.3-47
> > > gcc-3.2.3-47
> > > compat-gcc-7.3-2.96.128
> > > gcc-g77-3.2.3-47
> > > [root at kilburn torque-2.0.0p4-altix]# rpm -qa | grep glibc
> > > glibc-devel-2.3.2-95.33sgi306r1
> > > glibc-profile-2.3.2-95.33sgi306r1
> > > glibc-headers-2.3.2-95.33sgi306r1
> > > glibc-common-2.3.2-95.33sgi306r1
> > > glibc-2.3.2-95.33sgi306r1
> > > glibc-utils-2.3.2-95.33sgi306r1
> > > compat-glibc-7.x-2.2.4.32.6sgi306r1
> > > glibc-2.3.2-95.30
> > > glibc-debug-2.3.2-95.33sgi306r1
> > > [root at kilburn torque-2.0.0p4-altix]#
> > > 
> > > [root at kilburn torque-2.0.0p4-altix]# uname -a
> > > Linux kilburn 2.4.21-sgi306r6 #1 SMP Sat Jun 18 14:43:35 PDT 2005 ia64
> > > ia64 ia64 GNU/Linux[root at kilburn torque-2.0.0p4-altix]#
> > > 
> > > 
> > > So I'm at a loss at what I should look at now. The "talk to the SGI
> > > people" suggestion will be my next step. The only problem is that I have
> > > compiled all the other programs we are using here without issues. Since
> > > I have support with SGI I will contact them and see what they can come
> > > up with. Thanks everyone for the help. I'll post any results I come up
> > > with. Sincerely,
> > > 
> > > -Steve
> > > 
> > > 
> > > On Mon, 2006-01-02 at 21:18 +1100, Jeroen van den Muyzenberg wrote:
> > > > Hi Steve,
> > > > 
> > > > If this is truly happening "out of the box", then you should be talking
> > > > to SGI rather than this forum.
> > > > 
> > > > Jeroen
> > > > 
> > > > 
> > > > 
> > > > On Thu, 29 Dec 2005, Walter de Jong wrote:
> > > > 
> > > > > Hi,
> > > > >
> > > > > The short example program does compile on our Altix.
> > > > > It runs ProPack 3 SP6, limits.h is in the package
> > > > > glibc-headers-2.3.2-95.33sgi306r1
> > > > >
> > > > > So for PP4, look for a package named glibc-headers.
> > > > >
> > > > > (By the way, it gives _POSIX_PATH_MAX is 256, where I expected it to be
> > > > > 1024 or more. Ah well.)
> > > > >
> > > > > Greets,
> > > > >
> > > > >    --Walter
> > > > >
> > > > >
> > > > >
> > > > > Steve Young wrote:
> > > > >>  Hello, 	I hope all had a nice holiday. Anyhow, I still seem to have
> > > > >>  this issue
> > > > >>  with my Altix's. I have 3 of them out of the box from SGI. They all have
> > > > >>  the same problem. I tried compiling the below program and it also does
> > > > >>  the same thing. So it looks like I am missing some package in order to
> > > > >>  compile this? Any idea's what I should look for? Thanks,
> > > > >>
> > > > >>  -Steve
> > > > >>
> > > > >>
> > > > >>  On Thu, 2005-12-22 at 09:57 -0800, Garrick Staples wrote:
> > > > >> 
> > > > >> > On Wed, Dec 21, 2005 at 04:05:07PM -0500, Chemistry System Admin alleged:
> > > > >> > 
> > > > >> > > gcc -g -I../../../src/include -I../../../src/include -DHAVE_CONFIG_H -c
> > > > >> > > pbs_log.c
> > > > >> > > pbs_log.c:114: `_POSIX_PATH_MAX' undeclared here (not in a function)
> > > > >> > > pbs_log.c: In function `log_open':
> > > > >> > > pbs_log.c:181: `_POSIX_PATH_MAX' undeclared (first use in this 
> > > > >> > > function)
> > > > >> > > pbs_log.c:181: (Each undeclared identifier is reported only once
> > > > >> > > pbs_log.c:181: for each function it appears in.)
> > > > >> > > pbs_log.c: At top level:
> > > > >> > > pbs_log.c:114: storage size of `log_directory' isn't known
> > > > >> > > make[4]: *** [pbs_log.o] Error 1
> > > > >> > 
> > > > >> > So the following program won't build?  If not, something is broken with
> > > > >> > your system's header files.
> > > > >> > 
> > > > >> > # include <stdio.h>
> > > > >> > # include <limits.h>
> > > > >> > 
> > > > >> > int main() {
> > > > >> >   printf("%d\n",_POSIX_PATH_MAX);
> > > > >>> }
> > > > >> > 
> > > > >>> _______________________________________________
> > > > _______________________________________________
> > > > torqueusers mailing list
> > > > torqueusers at supercluster.org
> > > > http://www.supercluster.org/mailman/listinfo/torqueusers
> > > 
> > > _______________________________________________
> > > torqueusers mailing list
> > > torqueusers at supercluster.org
> > > http://www.supercluster.org/mailman/listinfo/torqueusers
> > > 
> > 
> > _______________________________________________
> > torqueusers mailing list
> > torqueusers at supercluster.org
> > http://www.supercluster.org/mailman/listinfo/torqueusers
> 



More information about the torqueusers mailing list