[torqueusers] torque gui-error linux 64 bits

Diego M. Vadell dvadell at linuxclusters.com.ar
Fri Feb 24 10:46:19 MST 2006


Hi Jhon,
   You need to install Xorg or XFree86. -lX11 is a flag to the linker
asking it to look for "libX11.so". You may not have that file (usuarlly
in /usr/X11/lib ) or configure is not looking for it in the right
place. Do you have that file?


 -- Diego.

> ok
>
> I created the link, I installed some rpm  (tcl-devel-8.4.7-2,
> tk-devel-8.4.7-2 tcl-8.4.7-2 and tk-8.4.7-2) and now when I run
>
> ./configure --enable-docs --enable-server --enable-mom --enable-gui
>
> the comand finished ok
> then I run the make commandand show the following error
>
> makedepend-sh: processing ./printtracking.c
> make[3]: Entering directory `/opt/torque-2.0.0p7/src/tools'
> gcc -g -I../../src/include -I../../src/include -I/usr/include
> -DHAVE_CONFIG_H - c ./../scheduler.tcl/pbs_tclWrap.c
> gcc -g -I../../src/include -I../../src/include -I/usr/include
> -DHAVE_CONFIG_H - c ./../scheduler.tcl/site_tclWrap.c
> gcc -g -I../../src/include -I../../src/include -I/usr/include
> -DHAVE_CONFIG_H - c pbsTclInit.c
> gcc -g -I../../src/include -I../../src/include -I/usr/include
> -DHAVE_CONFIG_H - o pbs_tclsh pbs_tclWrap.o site_tclWrap.o pbsTclInit.o
> ../lib/Liblog/liblog.a .. /lib/Libcmds/l
> ibcmds.a ../lib/Libnet/libnet.a ../lib/Libpbs/libpbs.a -L/usr/lib6 4
> -ltk8.4 -ltcl8.4 -L/usr/X11R6/lib64 -lX11 -lm
> /usr/bin/ld: cannot find -lX11
> collect2: ld returned 1 exit status
> make[3]: *** [pbs_tclsh] Error 1
> make[3]: Leaving directory `/opt/torque-2.0.0p7/src/tools'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/opt/torque-2.0.0p7/src/tools'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/opt/torque-2.0.0p7/src'
> make: *** [all] Error 2
>
> lX11 is a rpm packet??
>
> thanks
>
> Jhon
>
>
> On Fri, 24 Feb 2006 04:01:20 +0500, Garrick Staples <garrick at usc.edu>
> wrote:
>
>> On Thu, Feb 23, 2006 at 05:52:14PM -0500, Bisbal, Prentice alleged:
>>> cd /usr/lib
>>>
>>>  ls -l libtk*
>>> -rwxr-xr-x    1 root     root       763200 Sep  7 22:20 libtk8.3.so
>>> lrwxrwxrwx    1 root     root           11 Dec 30 12:44 libtk.so ->
>>> libtk8.3.so
>>> -rw-r--r--    1 root     root         3604 Sep  7 22:20 libtkstub8.3.a
>>> -rw-r--r--    1 root     root         5322 Sep  7 22:20 libtkx8.3.a
>>> -rwxr-xr-x    1 root     root         6900 Sep  7 22:20 libtkx8.3.so
>>>
>>> ln -s libtkx8.3.so libtkx.so
>>>
>>> After creating that link, it compiles. As far as I can tell, this is a
>>> bug in the RHEL3WS distribution.
>>
>> 2.0.0p7 should find tkx correctly without manually creating that
>> symlink.
>>
>
>
>
> --
> Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>



More information about the torqueusers mailing list