[torqueusers] Compiling xpbsmon

Diego Vadell dvadell at lantech.com.ar
Wed Feb 8 12:20:52 MST 2006


Hi Garrick,
  Sorry for the delay. I tried with torque-2.0.0p7 instead of the snapshot
and found an error. I ran:

./configure --prefix=/tmp/pbs-temp \
            --set-server-home=/tmp/pbs-temp/spool/PBS \
            --with-tclx
make

After a lot of output I get:

gcc -g -I../../src/include -I../../src/include -I/usr/include
-I/usr/include -DHAVE_CONFIG_H -o pbs_tclsh pbs_tclWrap.o site_tclWrap.o
pbsTclInit.o  ../lib/Liblog/liblog.a ../lib/Libcmds/libcmds.a
../lib/Libnet/libnet.a ../lib/Libpbs/libpbs.a -L/usr/lib64 -ltclx8.3
-ltkx8.3 -ltcl8.3 -lm
/usr/lib64/libtkx8.3.so: undefined reference to `Tk_MainLoop'
collect2: ld returned 1 exit status
make[3]: *** [pbs_tclsh] Error 1
make[3]: Leaving directory
`/export/home/admin/downloads/xpbsmon/torque-2.0.0p7/src/tools'

I can make this compile if I run that same last gcc line with "-ltk"
between "-L/usr/lib64" and "-ltclx8.3". So I think that maybe something is
not making tkx depend on tk.

Regards,
 -- Diego.


<quote who="Garrick Staples">
> Please try torque-2.0.0p6-snap.200601231521.tar.gz, it should find
> tcl/tclx/tk/tkx correctly on all distros and arches (hopefully!)
>
> --
> Garrick Staples, Linux/HPCC Administrator
> University of Southern California
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>



More information about the torqueusers mailing list