[torqueusers] torque requires --enable-debug to work

Andrew Sharpe andrew.sharpe1 at jcu.edu.au
Fri Oct 14 23:21:07 MDT 2005

Hi Garrick, thanks for the reply.

I've already tried without "--disable-rpp" with the same results, and 
I've tried a heap of other configurations as well.  I'll have a go at 
everything you've suggested and post results.

Thanks, Andrew

Garrick Staples wrote:

>On Wed, Oct 12, 2005 at 01:50:35PM +1000, Andrew Sharpe alleged:
>>Hi all,
>>I'm fairly new to torque but I think this is non-standard behaviour.  
>>I've verified that this problem exists on
>>using CentOS4.1 (full install) on x86_64.
>>The problem is that torque only works if I compile it with 
>>--enable-debug.  Here's the steps I follow to obtain the results:
>>NOTE: pbs is a CNAME to machine1, which correctly resolves to, 
>>machine2 correctly resolves to - by resolves I mean forward 
>>and reverse lookups are ok.
>>1. compile any of the above versions using the following commands
>>./configure --prefix=/usr/local --set-default-server=pbs 
>>--set-server-home=/var/spool/PBS --enable-server --enable-docs 
>>--enable-mom --enable-clients --enable-syslog --disable-rpp
>>make install
>Thanks for the very good debugging info!  Did you happen to check for
>anything in /var/log/messages?  Since you configured with
>--enable-syslog, there might be some valuable info.
>What is the server tcp_timeout ('p s tcp_timeout' in qmgr)?  That should
>be at least 6 or so.
>Please do 'set server log_level = 7' in qmgr and run 'momctl -q
>loglevel=7 -h machine1,machine2' and retry the tests.  That will add
>additional info to the server and mom logs.
>Also try again without '--disable-rpp' (be sure to reinstall and
>restart server and moms).
>torqueusers mailing list
>torqueusers at supercluster.org

Andrew Sharpe
APAC Project Officer
James Cook University Townsville
ph: +61 7 4781 4084

More information about the torqueusers mailing list