[torqueusers] Problems with output on very short jobs

Garrick Staples garrick at usc.edu
Fri Nov 25 12:21:28 MST 2005


On Fri, Nov 25, 2005 at 07:57:12PM +0100, Ronny T. Lampert alleged:
> >>I'm somewhat suspecting a race condition as the used.mem attributes are also
> >>"0".
> > You won't see any usage until the job has run at least $check_poll_time
> > seconds.
> 
> Can't be! Both jobs have 5 seconds walltime (way below job_stat_rate = 180),
> one has resources used, one hasn't - both are idential jobs.
> 
> 11/25/2005 16:32:28;0010;PBS_Server;Job;207535.rk001tsd.tsd.de;Exit_status=0
> resources_used.cput=00:00:00 resources_used.mem=2748kb
> resources_used.vmem=12464kb resources_used.walltime=00:00:05
> 
> 11/25/2005 16:35:57;0010;PBS_Server;Job;207536.rk001tsd.tsd.de;Exit_status=0
> resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
> resources_used.walltime=00:00:05

But you never know if MOM hits a $check_poll_time boundary (not server's
job_stat_rate) while your job is running.  With a 45 second
$check_poll_time, and a 5 second job, that's a... um, 1-in-9 chance of
seeing usage?

-- 
Garrick Staples, Linux/HPCC Administrator
University of Southern California
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20051125/b57458c2/attachment.bin


More information about the torqueusers mailing list