[torqueusers] Problems with output on very short jobs

Ronny T. Lampert telecaadmin at uni.de
Fri Nov 25 09:34:53 MST 2005


Hi,

a user of mine is having problems with PBS's .out and .err files on very
short jobs (5 seconds at peak) - they are simply empty or non-existant.

mom is using a $usecp directive. Torque is 1.2.0p5.


Job script looks like:
---
eval "HResults -PARAMS > output.eval && hresults2pvset.pl output.eval
-PARAMS 1> OUTPUT 2> OUTPUT2"
sleep 5
---


Server log entries:
---
11/25/2005 16:32:28;0010;PBS_Server;Job;207534.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=2736kb
resources_used.vmem=12464kb resources_used.walltime=00:00:06
11/25/2005 16:32:28;0010;PBS_Server;Job;207535.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=2748kb
resources_used.vmem=12464kb resources_used.walltime=00:00:05
11/25/2005 16:35:57;0010;PBS_Server;Job;207536.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
resources_used.walltime=00:00:05
11/25/2005 16:43:50;0010;PBS_Server;Job;207537.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:06:15 resources_used.mem=62328kb
resources_used.vmem=80892kb resources_used.walltime=00:06:22
11/25/2005 16:50:14;0010;PBS_Server;Job;207538.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
resources_used.walltime=00:00:06
11/25/2005 16:52:27;0010;PBS_Server;Job;207539.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
resources_used.walltime=00:00:05
11/25/2005 16:52:55;0010;PBS_Server;Job;207540.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
resources_used.walltime=00:00:05
11/25/2005 16:56:09;0010;PBS_Server;Job;207541.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
resources_used.walltime=00:00:06
11/25/2005 16:57:06;0010;PBS_Server;Job;207542.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
resources_used.walltime=00:00:06
11/25/2005 17:01:06;0010;PBS_Server;Job;207543.rk001tsd.tsd.de;Exit_status=0
resources_used.cput=00:00:00 resources_used.mem=0kb resources_used.vmem=0kb
resources_used.walltime=00:00:05
---

I'm somewhat suspecting a race condition as the used.mem attributes are also
"0".

Is there any known problem with redirecting the stdout/stderr in job scripts?
Has anything changed regarding the output-engine in more recent versions (so
I might bite the bullet and upgrade) ?

Cheers,
Ronny


More information about the torqueusers mailing list