[torqueusers] Bug ? Time discrepancy in the logs

Emmanuel Medernach medernac at clermont.in2p3.fr
Fri Jul 8 02:43:02 MDT 2005


Hello Torque users,

I would like to report a bug in the Torque log file, we are analysing 
our workload and the time reported by the logs are sometimes not 
coherent as for example:

    11/23/2004 13:51:56;E;11478.***;user=*** group=*** jobname=STDIN 
queue=infinite ctime=1101212467 qtime=1101212467 etime=1101212467 
start=1101212470 exec_host=***/0 Resource_List.cput=48:00:00 
Resource_List.neednodes=*** Resource_List.nodect=1 Resource_List.nodes=1 
Resource_List.walltime=72:00:00 session=10781 end=1101214316 
Exit_status=0 resources_used.cput=00:30:26 resources_used.mem=122672kb 
resources_used.vmem=139888kb resources_used.walltime=00:30:07

We have end - start = 30:46, a walltime of 30:07 and a CPU time of 30:26.

How is it possible to have CPU time > walltime ?  And why end - start is 
so different from the Wall Time ?

Other jobs show the same time discrepancy:

    10/06/2004 17:11:39;E;334.***;user=*** group=*** jobname=STDIN 
queue=short ctime=1097075261 qtime=1097075261 etime=1097075261 
start=1097075498 exec_host=***/0 Resource_List.cput=00:15:00 
Resource_List.neednodes=*** Resource_List.nodect=1 Resource_List.nodes=1 
Resource_List.walltime=02:00:00 session=0 end=1097075499 Exit_status=0 
resources_used.cput=00:00:03 resources_used.mem=13060kb 
resources_used.vmem=23460kb resources_used.walltime=00:00:06

It has a CPU time of 3 seconds, but end - start is only one second and a 
walltime of 6 seconds ?

Any help would be very appreciated,

Best regards,
--
Emmanuel Medernach


More information about the torqueusers mailing list